Forum Index Search Forum Register Log in

Runs on XP to Win 10

Current

Download 7.0

Download 7.1 Beta5 upgrade



A donation makes a contribution towards the time and effort that's going in to running this site.

Steffen

Contact:
My mail address is
at the top of the paypal form :

Your donations will help to keep this site alive and well.


Update your links !! November 2016 the forum is at www.apachelounge.com/sambar

In the forum there are links to sambarserver.info,
replace "sambarserver.info" with "apachelounge.com/sambar"
Sambar 7 and PHP 5.3+

 
Post new topic   Reply to topic    Sambar Forum Index -> Lounge
View previous topic :: View next topic  
Author Message
lrdsatyr8



Joined: 04 Apr 2014
Posts: 3

PostPosted: Fri 04 Apr '14 10:59    Post subject: Sambar 7 and PHP 5.3+ Reply with quote

I realize that PHP stopped producing the PHPISAPI.DLL for versions 5.3 and above but has anyone figured out a way to use PHP 5.5 with Sambar yet or is it a lost cause and I should move on with another server program?
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 413
Location: Netherlands

PostPosted: Fri 04 Apr '14 11:36    Post subject: Reply with quote

You can run it as CGI. PHP 5.5.x NTS runs fine as cgi, but performance is less.

Steffen
Back to top
View user's profile Visit poster's website
lrdsatyr8



Joined: 04 Apr 2014
Posts: 3

PostPosted: Fri 04 Apr '14 12:46    Post subject: Reply with quote

How would I go about setting that up? In the Mappings.ini?
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 413
Location: Netherlands

PostPosted: Fri 04 Apr '14 13:02    Post subject: Reply with quote

In mappings.ini :
[cgi]
*.php = x:/xxxx/php-cgi.exe

substitute x/xxxx to your php folder. And remove the php [isapi] entry .

And in config.ini you must have in the CGI Extensions *.php. I have also perl and cgi scripts:
CGI Extensions = *.cgi *.pl *.php

Steffen
Back to top
View user's profile Visit poster's website
lrdsatyr8



Joined: 04 Apr 2014
Posts: 3

PostPosted: Sat 05 Apr '14 22:50    Post subject: Reply with quote

Well... I tried that and it didn't work... here's the error I got

ERROR: ###.###.###.### Failure executing CGI process: c:\php\php-cgi.exe c:\server\docs\home\index.php

When I try to go to my site, I get an 500 error and the default page that says:

Internal System Error

An internal system error has occurred which prevents us from responding to your request.

Any other suggestions?
Back to top
View user's profile
Steffen



Joined: 07 Jun 2004
Posts: 413
Location: Netherlands

PostPosted: Sun 06 Apr '14 8:13    Post subject: Reply with quote

Anything in the php error log and/or Windows Event Viewer ?

You can try to disable all the extensions in php.ini and try phpinfo.php :


<?php

phpinfo();

?>
Back to top
View user's profile Visit poster's website
aj250037



Joined: 27 Sep 2014
Posts: 1

PostPosted: Sat 27 Sep '14 3:54    Post subject: Reply with quote

Steffen's instructions on mappings and config ini files, worked perfectly.
I am running Sambar on Win 8.1 with PHP 5.6.0[Win64ThreadSafe Install]
Back to top
View user's profile

Post new topic   Reply to topic    Sambar Forum Index -> Lounge
Page 1 of 1