logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache configuration for Windows Network Load Balancer(WNLB)

 
Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking



View previous topic :: View next topic  
Author Message
vinaysys



Joined: 28 Mar 2008
Posts: 1

PostPosted: Fri 28 Mar '08 18:20    Post subject: Apache configuration for Windows Network Load Balancer(WNLB) Reply with quote

Hi All,

We have two Apache Web Servers running in windos machines and they are communicating with Clusterd JBoss servers by ModjK configuration.

Fronting the two apache web servers we have an IIS server which communicates to apache web servers using ISAPI Rewrite software.

For load balancing these two apache servers we have configured the Windows NLB and assigned the Virtual IP address for NLB.

1.2.3.1 => Apache 1
1.2.3.2 => Apache 2
1.2.3.3 => NLB Virtual IP address

When we access the application using the Apache 1 IP address and Apache 2 IP address we are able to access the application on the browser.
like http://1.2.3.1:80/example & http://1.2.3.2:80/example are working fine but if we try to access the application through NLB IP address as http://1.2.3.3:80/example we are unable to access the application.

We have not done any special configuration in httpd.conf files of Apache 1 & 2 for NLB.

Please some one let me know why we are unable to access the application.

Is there any special configuration must be done in apache for achieving these.

Thanks
Vinay
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 02 Apr '08 17:07    Post subject: Reply with quote

Anything about that in the error logs? Can you reach some simpler folder like the icons folder? Any chance to log in your application?
What kind of error message do you get from the NLB / in the browser?
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Wed 02 Apr '08 18:11    Post subject: Reply with quote

When you set up your Windows Network Load Balancing, did you remember to create a "port rule" for port 80 (selecting "multiple hosts")?

-tom-
Back to top
sravi



Joined: 28 Jul 2008
Posts: 1

PostPosted: Mon 28 Jul '08 17:09    Post subject: Reply with quote

Hi Tom,

I also having the same problem. When ever I hit to the nlb ip it just display "It works". I have setup up the port rule to use port 80 multiple hosts.

Pls. advice. Urgent Help need.

Regards,
Ravi Crying or Very sad
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking
Page 1 of 1