logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Trouble after compiling

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Alan



Joined: 15 Jun 2006
Posts: 3

PostPosted: Thu 15 Jun '06 16:18    Post subject: Trouble after compiling Reply with quote

So on. I have WinXP SP2 and Visual Studio .NET 2005 installed. Visual C++ compiles some simple programs very well, but... with Apache 2.2.2...

I compiled Apache 2.2.2 with OpenSSL and Zlib twice, with diffrent instructions, but always get the same result: "The application has failed to start because MSVCR80.dll was not found. Re-installing the application may fix this problem".


Then I put MSVCR80.dll and Microsoft.VC80.CRT.manifest from %VSDIR%\VC\redist\x86\Microsoft.VC80.CRT to Apache bin dir, and then get that error: "An application has made an attempt to load the C runtime library incorrectly."


And after then follow next error:


I don't know what to do...

I download Apache.2.2.2 archive from that site, and it works great. I did not found any MSVCR80.dll in bin dir in that archive, so, i think, that my system can found it.

I followd by instructions from Apache web-site and one from another, but have the same result. Can author of apache distr from this site wrote an instruction how to compile Apache?

However, I compile OpenSSL with that compiler, and it works fine, but Apache did not work at all Sad

Help, Please. Sorry for mistakes...
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 15 Jun '06 17:52    Post subject: Reply with quote

What happens when you install www.microsoft.com/downloads/details.aspx?familyid=32BC1BEE-A3F9-4C13-9C99-220B62A191EE&displaylang=en ?

Steffen
Back to top
Alan



Joined: 15 Jun 2006
Posts: 3

PostPosted: Fri 16 Jun '06 14:23    Post subject: Reply with quote

I found some package in %VCDIR%\SDK\v2.0\BootStrapper\Packages\vcredist_x86. Package named vcredist_x86.exe version 2.0.50727.42 and 2,52Mb. I installed them, but still error.

I download package from link below. Package vcredist_x86.exe and 2,56Mb. Is this packages diffrent? I installed package, but still have an error.
Back to top
Alan



Joined: 15 Jun 2006
Posts: 3

PostPosted: Sat 17 Jun '06 12:18    Post subject: Reply with quote

All right. I installed on another HDD Windows 98, and try to start up ApacheMonitor from my compilation... and it works! I can't understand why, but it works. Magick...
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1