logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



403s for every request

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
SirG3



Joined: 16 Dec 2005
Posts: 3

PostPosted: Fri 16 Dec '05 17:08    Post subject: 403s for every request Reply with quote

For every request I get a 403 error, and a line in the error.log like this:
Quote:

[Fri Dec 16 09:02:53 2005] [error] [client 24.59.88.76] (20023)The given path was above the root path: Cannot map GET /wordpress/ HTTP/1.1 to file


I've checked the DocumentRoot for the server and for the vhost:
Quote:
DocumentRoot "e:/Server/Users/sirg3"

Quote:
<VirtualHost *:80>
ServerAdmin TheSirG3@gmail.com
DocumentRoot e:/Server/Users/sirg3/
ServerName sirg3.homeip.net
</VirtualHost>


Any ideas?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2580
Location: Hilversum, NL, EU

PostPosted: Fri 16 Dec '05 17:22    Post subject: Reply with quote

The message: (20023)The given path was above the root path.......
Indicates that there is some wrong in your paths in an Directory/Location etc. directive.

Try to remove the trailing slash in the vhost DocumentRoot e:/Server/Users/sirg3/

If that not helps, try to remove the root directive for the server,

Steffen
Back to top
SirG3



Joined: 16 Dec 2005
Posts: 3

PostPosted: Fri 16 Dec '05 17:29    Post subject: Reply with quote

Wow, that did it. Thanks!

Edit: Hm, spoke too soon, the main VHost works (sirg3.homeip.net), but the others (like rgov.sirg3.homeip.net or copacetic.dnsalias.com) don't. Those paths don't have a trailing slash...
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2580
Location: Hilversum, NL, EU

PostPosted: Fri 16 Dec '05 17:44    Post subject: Reply with quote

Did you try to remove the root directive for the server: DocumentRoot "e:/Server/Users/sirg3 ?

I do not have that, only DocumentsRoot in the vhosts I have.

Steffen
Back to top
SirG3



Joined: 16 Dec 2005
Posts: 3

PostPosted: Fri 16 Dec '05 17:58    Post subject: Reply with quote

D'oh.

Quote:
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>


Fixed that to allow and it works =).
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1