logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Python And WSGI Support

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
firefly



Joined: 25 Aug 2012
Posts: 2
Location: Australia

PostPosted: Sat 25 Aug '12 14:26    Post subject: Python And WSGI Support Reply with quote

Any one solved this one?

I am running Window Vista Business 32 bit OS:
• Apache 2.4
• Install from part of XAMPP Version 1.8.0
• Python 2.7.3
I want to add Python support to Apache so I did the following.
I changed the Apache's hpttpd.conf file to add the following at line 141
LoadModule wsgi_module modules/mod_wsgi.so
The file is in the Apache\modules folder
After modifying the httpd.conf Apache will not start with non specific error message with a reference to the System Event Log.

Message in the Event log is "The Apache service named reported the following error: >>>
httpd.exe: Syntax error on line 141 of C:/XAMPP/apache/conf/httpd.conf: Cannot load C:/XAMPP/apache/modules/mod_wsgi.so into server: The specified procedure could not be found "
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Sat 25 Aug '12 14:50    Post subject: Reply with quote

What does the System Event Log or Apache error.log say ?

Sure you have a 2.4 Win32 mod_wsgi.so Python 2.7.3 ?
Back to top
firefly



Joined: 25 Aug 2012
Posts: 2
Location: Australia

PostPosted: Sun 26 Aug '12 1:24    Post subject: Apache and WSGI support Reply with quote

Steffen thank you. The problem which you directed my attention to is WSGI version 3.3 is not compatible with Apache 2.4. WSGI version 4.0 will be when it is available. So I am now looking for a work about to run WSGI 3.3 in Apache 2.4 until the update is available.

The Event message in my previous post was from the Application Event log
Apache log provides no information on the issue
System Event log follows
"System
- Provider
[ Name] Service Control Manager
[ Guid] {555908D1-A6D7-4695-8E1E-26931D2012F4}
[ EventSourceName] Service Control Manager
- EventID 7024
[ Qualifiers] 49152
Version 0
Level 2
Task 0
Opcode 0
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2012-08-25T23:05:47.000Z
EventRecordID 1090047
Correlation
- Execution
[ ProcessID] 0
[ ThreadID] 0
Channel System
Computer DeskTop1-PC
Security
- EventData
param1 apache2.4
param2 1 (0x1) "
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1