logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



LUA Version

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
idblew



Joined: 14 Nov 2014
Posts: 10
Location: Melbourne, Australia

PostPosted: Thu 10 Dec '15 1:55    Post subject: LUA Version Reply with quote

Is there a reason why 2.4.x is compiled using LUA 5.1.5 rather than the latest 5.3.x (currently 5.3.2)?

I don't normally compile my Apache with LUA, but was considering producing a complete build with all dependencies.

Thanks
Ian
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Thu 10 Dec '15 12:30    Post subject: Reply with quote

Updated to 5.2.4 in the download at https://www.apachelounge.com/viewtopic.php?p=32392

Build with LUA_COMPAT_ALL

I see still 5.3 compatibility discussions around, like mod_security. With mod_security it is static built in, so that we keep on 5.1.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Thu 10 Dec '15 15:21    Post subject: Reply with quote

When you are interested I can build a mod_lua for 5.3.

When yes, but what is the best build:

There are quite some options for compatibility with previous versions, see in /src/luaconf.h , what to choose ?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Fri 11 Dec '15 3:35    Post subject: Reply with quote

Seeing as these are still used in mod_lua/2.4.x;

lua_strlen()
lua_objlen()
luaL_register

I'd say you need -DLUA_COMPAT_5_1 in 5.3 which should be good enough to cover it. I do not see anything in LUA_COMPAT_5_2 being used in mod_lua.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1