logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Editing httpd.conf file prevents Apache 2 from running...

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
firewall



Joined: 08 Jan 2006
Posts: 3

PostPosted: Sun 08 Jan '06 8:31    Post subject: Editing httpd.conf file prevents Apache 2 from running... Reply with quote

I'm trying to have Apache2 run with PHP4 support, but doing so requires that i edit the httpd.conf file. But, everytime i edit it, and try to start/restart Apache2 it fails to load. But, when i undo all changes to the httpd.conf file, Apache2 starts working again. Anyone have an idea on why that is, and how to fix that?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2580
Location: Hilversum, NL, EU

PostPosted: Sun 08 Jan '06 13:57    Post subject: Reply with quote

What do you edit ?

What errors you get and which version of Apache are you running ?

Steffen
Back to top
firewall



Joined: 08 Jan 2006
Posts: 3

PostPosted: Mon 09 Jan '06 16:32    Post subject: Reply with quote

Unknown(): (null): Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=1
PHP compiled with module API=20020429, debug=0, thread-safety=1
These options need to match

(i see this 3 times)
---

Unknown(): Unable to load dynamic library 'C:/WebServer/wamp/php/ext/php_pdo_sqlite.dll' - The specified module could not be found.

Unknown(): Unable to load dynamic library 'C:/WebServer/wamp/php/ext/php_sqlite.dll' - The specified module could not be found.

(i see this twice, eventhough those files are located there)
---

I only make basic configuration to httpd.conf. I have version 2.0.55 of Apache.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2580
Location: Hilversum, NL, EU

PostPosted: Mon 09 Jan '06 19:12    Post subject: Reply with quote

Looks like that you are mixing versions of your php modules.

You are using a wamp package ?
Back to top
firewall



Joined: 08 Jan 2006
Posts: 3

PostPosted: Tue 10 Jan '06 4:53    Post subject: Reply with quote

Quote:

You are using a wamp package ?

Yea, I am. I figured I can downgrade to PHP4 by just replacing a few files, and editing the httpd.conf file. Guess it's not going as planned...

EDIT:
Fixed my problem! Dont need help anymore!
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1