logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache httpd 2.4.23 available :: Updated

 
Post new topic   Reply to topic    Apache Forum Index -> News & Hangout



View previous topic :: View next topic  
Author Message
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Tue 05 Jul '16 10:16    Post subject: Apache httpd 2.4.23 available :: Updated Reply with quote

Apache httpd 2.4.23 GA is now available at the download pages.

For the ASF and Apachelounge changes over 2.4.23 (2.4.21 and 2.4.22 not released)
see https://www.apachelounge.com/Changelog-2.4.html

VC14: now build with Visual Studio 2015 Update 3. Recommended to install the new C++ Redistributable Visual Studio 2015 from the download page.

27 September 2016: Upgrade Openssl to 1.0.2j
23 September 2016: Upgrade Openssl to 1.0.2i (was 1.0.2h)


Build with:
nghttp2 1.12.0
apr 1.5.2 with IPv6 enabled
apr-util 1.5.4 with Crypto OpenSSL enabled
apr-iconv 1.2.1
openssl 1.0.2j +asm
zlib 1.2.8 +asm
pcre 8.39 with JIT, SUPPORT_UTF8 and REBUILD_CHARTABLES enabled
httpd.exe with OPENSSL_Applink and VC14 SupportedOS Manifest
libxml2 2.9.4
lua 5.2.4 with LUA_COMPAT_ALL
expat 2.2.0

VC11 and VC14 versions do not run with XP and 2003, use the VC10 version.

Documentation: http://httpd.apache.org/docs/2.4/ attention there when you want to Upgrade to 2.4 from 2.2

When you have hangs, slow traffic and/or when having in your log entries like Asynchronous AcceptEx failed. You can try the following settings:

AcceptFilter http none
AcceptFilter https none
EnableSendfile off
EnableMMAP off

Enjoy,

Steffen

------------------------ ASF Announcement ---------------------
Apache HTTP Server 2.4.23 Released

The Apache Software Foundation and the Apache HTTP Server Project
are pleased to announce the release of version 2.4.23 of the Apache
HTTP Server ("Apache"). This version of Apache is our latest GA
release of the new generation 2.4.x branch of Apache HTTPD and
represents fifteen years of innovation by the project, and is
recommended over all previous releases. This release of Apache is
principally a feature and bug fix release.

NOTE: Versions 2.4.22 and 2.4.21 were not released.

We consider this release to be the best version of Apache available, and
encourage users of all prior versions to upgrade.


Last edited by Steffen on Thu 29 Sep '16 11:13; edited 7 times in total
Back to top
Smitty



Joined: 03 Jan 2008
Posts: 195

PostPosted: Tue 05 Jul '16 14:35    Post subject: Reply with quote

Is mod_h2 1.5.10 in this version?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Tue 05 Jul '16 15:01    Post subject: Reply with quote

1.5.11 plus the fix in 2.4.22.
Back to top
Smitty



Joined: 03 Jan 2008
Posts: 195

PostPosted: Tue 05 Jul '16 19:22    Post subject: Reply with quote

Fantastic! Thank you.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Wed 06 Jul '16 6:57    Post subject: Reply with quote

Steffen wrote:
1.5.11 plus the fix in 2.4.22.

This is a bit cryptic. Did you change the mod_http2 that is in the sources of Apache 2.4.23 at http://httpd.apache.org/dev/dist/ ??
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Wed 06 Jul '16 7:56    Post subject: Reply with quote

Yes.

Edit: answer must be no, see below. Was to hurry.

In 2.4.21 the version was 1.5.11. With version 2.4.22 there was a fix and the mod_http2 version was not upped.


Last edited by Steffen on Wed 06 Jul '16 10:23; edited 1 time in total
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Wed 06 Jul '16 9:17    Post subject: Reply with quote

Then your 'Yes' must be a 'No': you just used the mod_http2 sources that were in the Apache 2.4.23 tarballs. Thanks.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Mon 11 Jul '16 11:15    Post subject: Reply with quote

The version on https://github.com/icing/mod_h2/releases is 1.5.12 now. I am not sure if other things have changed, compared to the release tarball of Apache 2.4.23.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 536

PostPosted: Mon 11 Jul '16 11:46    Post subject: Reply with quote

Only change compared to 2.4.23 is: fixed connection flushing when handling SETTINGS and no stream is open.

It's a small/minor one
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Fri 23 Sep '16 10:49    Post subject: Reply with quote

Upgrade OpenSSL to 1.0.2i (was 1.0.2h).
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Wed 28 Sep '16 12:21    Post subject: Reply with quote

Upgrade OpenSSL to 1.0.2j.
Back to top
blackbird



Joined: 10 Nov 2016
Posts: 1
Location: USA

PostPosted: Thu 10 Nov '16 19:06    Post subject: Reply with quote

Hello Steffen,
I asked the same question in the email. I need to upgrade openssl to 1.1.0+ because of security vulnerability, but don't know how to do it. I wonder if you plan to upgrade it soon? Thanks!
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 536

PostPosted: Thu 10 Nov '16 19:09    Post subject: Reply with quote

Apache does not support OpSSL 1.1.x yet.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Thu 10 Nov '16 19:42    Post subject: Reply with quote

Do you know if anybody is working on it? I did not see any sign of that in de apache-devel mailinglist...
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 536

PostPosted: Thu 10 Nov '16 19:52    Post subject: Reply with quote

There is a test branche : http://svn.apache.org/viewvc/httpd/httpd/branches/

No activity last months.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Thu 10 Nov '16 19:58    Post subject: Reply with quote

And the only activity seems to be z/OS related:
http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x-openssl-1.1.0-compat/
http://svn.apache.org/viewvc/httpd/httpd/branches/2.4.x-openssl-1.1.0-compat/modules/ssl/
Back to top


Post new topic   Reply to topic    Apache Forum Index -> News & Hangout
Page 1 of 1