logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Need mod_qos 64bit ?

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
duyvu12



Joined: 02 Nov 2016
Posts: 4

PostPosted: Mon 28 Nov '16 2:51    Post subject: Need mod_qos 64bit ? Reply with quote

Dear all members,
Currently I have some issue with mod_antiloris.
This mod makes the Apache from ver 2.4.20 have some issue like this:

Quote:
Total accesses: 540420985 - Total Traffic: 3100272384.0 GB192000 requests/sec - 1.6 GB/second - 1.7 GB/request7 requests currently being processed, 993 idle workers


So please help me with this mod in 64bit!
Thanks for your help!

Quote:

http://mod-qos.sourceforge.net/
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2536
Location: Hilversum, NL, EU

PostPosted: Mon 28 Nov '16 10:54    Post subject: Reply with quote

See:

https://www.apachelounge.com/viewtopic.php?t=4574
There: mod_qos is not portable without some major work

https://www.apachelounge.com/viewtopic.php?t=5398
There: No, that's a can of worms I do not want to open
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2101
Location: Sun Diego, USA

PostPosted: Wed 30 Nov '16 19:30    Post subject: Reply with quote

Since both those posts were mine, and it certainly cannot be built on VC11 or prior without so work, I said that. VC14 on the other hand might do it. So I'm willing to give it a shot.

vc14 is C99 compatible and this has some C11 (2011) stuff in it but I see at least one C11 item used by this module in VC14, so maybe everything needed is there.
Back to top
duyvu12



Joined: 02 Nov 2016
Posts: 4

PostPosted: Sat 03 Dec '16 4:20    Post subject: Reply with quote

Thanks all for your information!
I really like mod_evasive + antiloris but now my web server structure cannot use them...

Quote:
Clients -> Proxy (Load balance) -> Servers


Mod_QOS supports 1 thing (like this) than the others:
Quote:
QS_ClientIpFromHeade X-Forwarded-For-Varnish


So in case we cannot work with QOS, can someone suggest me 1 module for DDOS preventing pls.

Thanks all!
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1