logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



Apache 2.4.25 available :: Updated

 
Post new topic   Reply to topic    Apache Forum Index -> News & Hangout



View previous topic :: View next topic  
Author Message
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2516
Location: Hilversum, NL, EU

PostPosted: Tue 20 Dec '16 11:12    Post subject: Apache 2.4.25 available :: Updated Reply with quote

Apache httpd 2.4.25 GA is now available at the download pages.

27 Januari 2017:
Updated with FIX mod_proxy (ajp) crash, OpenSSL 1.0.2k, PCRE 8.40, ZLIB 1.2.11
For mod_proxy crashes: see https://www.apachelounge.com/viewtopic.php?t=7470


For the ASF and Apachelounge changes (2.4.24 not released)
https://www.apachelounge.com/Changelog-2.4.html

Build with:
nghttp2 1.17.0
apr 1.5.2 with IPv6 enabled
apr-util 1.5.4 with Crypto OpenSSL enabled
apr-iconv 1.2.1
openssl 1.0.2k +asm
zlib 1.2.11
pcre 8.40 with JIT, SUPPORT_UTF8 and REBUILD_CHARTABLES enabled
httpd.exe with OPENSSL_Applink and VC14 SupportedOS Manifest
libxml2 2.9.4
lua 5.2.4 with LUA_COMPAT_ALL
expat 2.2.0

VC11 and VC14 versions do not run with XP and 2003.

Documentation: http://httpd.apache.org/docs/2.4/ attention there when you want to Upgrade to 2.4 from 2.2

When you have hangs, slow traffic and/or when having in your log entries like Asynchronous AcceptEx failed. You can try the following settings:

AcceptFilter http none
AcceptFilter https none
EnableSendfile off
EnableMMAP off

Enjoy,

Steffen

------------------------ ASF Announcement ---------------------


The Apache Software Foundation and the Apache HTTP Server Project
are pleased to announce the release of version 2.4.25 of the Apache
HTTP Server ("Apache"). This version of Apache is our latest GA
release of the new generation 2.4.x branch of Apache HTTPD and
represents fifteen years of innovation by the project, and is
recommended over all previous releases. This release of Apache is
principally a security, feature, and bug fix release.

NOTE: Version 2.4.24 was not released.

We consider this release to be the best version of Apache available, and
encourage users of all prior versions to upgrade.


Last edited by Steffen on Sat 28 Jan '17 12:19; edited 8 times in total
Back to top
Smitty



Joined: 03 Jan 2008
Posts: 195

PostPosted: Wed 21 Dec '16 5:25    Post subject: Reply with quote

Is mod_http2 version 1.8.3 in the download? Or do we have to update to 1.8.3 manually?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2098
Location: Sun Diego, USA

PostPosted: Wed 21 Dec '16 6:41    Post subject: Reply with quote

Yes, it's 1.8.3
http://svn.apache.org/viewvc/httpd/httpd/tags/2.4.25/modules/http2/h2_version.h?revision=1774646&view=co
Back to top
jchampion



Joined: 21 Dec 2016
Posts: 1

PostPosted: Wed 21 Dec '16 9:20    Post subject: Re: Apache 2.4.15 available Reply with quote

Steffen wrote:
When you have hangs, slow traffic and/or when having in your log entries like Asynchronous AcceptEx failed. You can try the following settings:

AcceptFilter http none
AcceptFilter https none

With the removal of the 'data' AcceptFilter in 2.4.24, which was a major source of hangs with modern web browsers, it may be time to start phasing out this advice. The pool of users with software that interferes with the now-default 'connect' filter is hopefully shrinking.
Back to top
Izomye



Joined: 15 Dec 2016
Posts: 7
Location: Hammerfest

PostPosted: Wed 21 Dec '16 17:47    Post subject: Reply with quote

Thanks for your good work, steffen. But in the name of the topic is a worng version Smile
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 530

PostPosted: Wed 21 Dec '16 18:23    Post subject: Reply with quote

Oops, corrected.

Thanks
Back to top
jack01



Joined: 28 Feb 2014
Posts: 27

PostPosted: Fri 06 Jan '17 14:40    Post subject: Reply with quote

Will there be Apache 2.4.25 also available for V10?

There isn't currently:
https://www.apachelounge.com/download/VC10/
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 530

PostPosted: Fri 06 Jan '17 14:46    Post subject: Reply with quote

See https://www.apachelounge.com/viewtopic.php?t=7451
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2516
Location: Hilversum, NL, EU

PostPosted: Fri 27 Jan '17 13:28    Post subject: Reply with quote

Updated Openssl, PCRE, ZLIB and fix mod_proxy crash, see start post above.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> News & Hangout
Page 1 of 1