logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



error 403 - forbidde.. to access /qgis/qgis_mapserv.fcgi.exe

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
tdkappa



Joined: 15 Feb 2017
Posts: 5

PostPosted: Tue 10 Oct '17 13:52    Post subject: error 403 - forbidde.. to access /qgis/qgis_mapserv.fcgi.exe Reply with quote

Hello to everyone,

I just Install Apache 2.2.14(win32) mod_fcgid/2.3.6 on Windows 10 x64

this is part of my httpd.conf

Code:

#the path below is correct!
include "C:\OSGeo4W/httpd.d/httpd_qgis.conf"


and this is https_qgis.conf

Code:

AddHandler cgi-script .cgi .pl .exe

LoadModule fcgid_module modules/mod_fcgid.so

DefaultInitEnv PATH "C:\OSGeo4W\bin;C:\OSGeo4W\apps\qgis\bin;C:\OSGeo4W\apps\grass\grass-@grassversion@\bin;C:\OSGeo4W\apps\grass\grass-@grassversion@\lib;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem"
DefaultInitEnv QGIS_PREFIX_PATH "C:\OSGeo4W\apps\qgis"
DefaultInitEnv QT_PLUGIN_PATH "C:\OSGeo4W\apps\qgis\qtplugins;C:\OSGeo4W\apps\qt4\plugins"
DefaultInitEnv TEMP "C:\Users\admin\AppData\Local\Temp"
DefaultInitEnv PYTHONHOME "C:\OSGeo4W\apps\Python27"

ScriptAlias /cgi-bin/ "C:\OSGeo4W/bin/"
ScriptAlias /qgis/ C:\OSGeo4W/apps/qgis/bin/
#ScriptAlias /cgi-bin/ C:\OSGeo4W/apps/qgis/bin/


<Directory "C:\OSGeo4W/apps/qgis/bin/">
    SetHandler fcgid-script
    Options ExecCGI
    #Order allow,deny
    #Allow from all
    Require all granted
</Directory>


Apache start correctly, without errors, but if I try to browse this address:

http://localhost/qgis/qgis_mapserv.fcgi.exe?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

I have this error 403:

You don't have permission to access /qgis/qgis_mapserv.fcgi.exe on this server.

How can I resolve ?!

The path I write above, are correct !
Back to top
pschmehl



Joined: 13 Oct 2017
Posts: 7
Location: United States, Richardson, TX

PostPosted: Sat 14 Oct '17 1:25    Post subject: Reply with quote

What Order directives do you have in your conf file? What's in your .htaccess file in the root of the site?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1