logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



With mod_md v1.0.3 I see some restarts

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
pbhq



Joined: 17 Mar 2013
Posts: 7
Location: Germany

PostPosted: Tue 21 Nov '17 21:14    Post subject: Reply with quote

Steffen wrote:
Updated mod_md to version 1.0.3, solves issue with the new Agreement.


Thank you!

One question: With the new version I see some restarts of mod_md?

It this a bug or feature?

Code:


[Sun Nov 19 16:26:42.685219 2017] [md:info] [pid 1676:tid 412] AH10071: mod_md (v1.0.3-git), initializing...
[Sun Nov 19 16:26:43.621221 2017] [md:info] [pid 2228:tid 352] AH10071: mod_md (v1.0.3-git), initializing...
[Sun Nov 19 16:26:43.683621 2017] [md:info] [pid 2228:tid 352] AH10071: mod_md (v1.0.3-git), initializing...

[Mon Nov 20 03:31:17.196962 2017] [mpm_winnt:notice] [pid 1676:tid 412] AH00428: Parent: child process 2228 exited with status 255 -- Restarting.
[Mon Nov 20 03:31:17.249965 2017] [md:info] [pid 1676:tid 412] AH10071: mod_md (v1.0.3-git), initializing...
[Mon Nov 20 03:31:17.674990 2017] [md:info] [pid 5004:tid 352] AH10071: mod_md (v1.0.3-git), initializing...
[Mon Nov 20 03:31:17.733993 2017] [md:info] [pid 5004:tid 352] AH10071: mod_md (v1.0.3-git), initializing...

[Mon Nov 20 10:33:56.968458 2017] [mpm_winnt:notice] [pid 1676:tid 412] AH00428: Parent: child process 5004 exited with status 255 -- Restarting.
[Mon Nov 20 10:33:57.022461 2017] [md:info] [pid 1676:tid 412] AH10071: mod_md (v1.0.3-git), initializing...
[Mon Nov 20 10:33:57.434485 2017] [md:info] [pid 2532:tid 352] AH10071: mod_md (v1.0.3-git), initializing...
[Mon Nov 20 10:33:57.496489 2017] [md:info] [pid 2532:tid 352] AH10071: mod_md (v1.0.3-git), initializing...

[Tue Nov 21 04:33:01.290622 2017] [mpm_winnt:notice] [pid 1676:tid 412] AH00428: Parent: child process 2532 exited with status 255 -- Restarting.
[Tue Nov 21 04:33:01.364626 2017] [md:info] [pid 1676:tid 412] AH10071: mod_md (v1.0.3-git), initializing...
[Tue Nov 21 04:33:01.784650 2017] [md:info] [pid 4984:tid 356] AH10071: mod_md (v1.0.3-git), initializing...
[Tue Nov 21 04:33:01.844653 2017] [md:info] [pid 4984:tid 356] AH10071: mod_md (v1.0.3-git), initializing...

Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Tue 21 Nov '17 21:38    Post subject: Reply with quote

Looks Apache is crashing every few hours.

Running windows ?

Does it doing all the time ?

Are the certificates good ?

Only happens after you updated to 1.0.3 ?

Was it without the crashes with earlier versions of mod_md ?

To see more set : LogLevel info md:trace2 ssl:notice

You can post your error log with pastbin http://apaste.info/ or http://www.hastebin.com/
Back to top
pbhq



Joined: 17 Mar 2013
Posts: 7
Location: Germany

PostPosted: Tue 21 Nov '17 23:51    Post subject: Reply with quote

admin wrote:
Looks Apache is crashing every few hours.

Running windows ?


Win7Pro with the current VC15 Apache 2.4 compilation

admin wrote:
Are the certificates good ?


Yes, all three certificates (1x main, 2x alias).

admin wrote:
Only happens after you updated to 1.0.3 ?


9 days without any problems (1.0.1) and now every day some restarts with the 1.0.3 release.

admin wrote:
To see more set : LogLevel info md:trace2 ssl:notice


We will see ... Wink

I also played a bit with the restart routine in the last few days, because the Apache service is not easy to restart as a user. Obtaining the elevated admin rights via RunAs and the Task Scheduler does not work via MDCmdNotify

Maybe I have so captured me a problem . Shocked
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Wed 22 Nov '17 0:03    Post subject: Reply with quote

Best to remove MDCmdNotify and see if it still is crashing.
Back to top
pbhq



Joined: 17 Mar 2013
Posts: 7
Location: Germany

PostPosted: Wed 22 Nov '17 20:38    Post subject: Reply with quote

admin wrote:
Best to remove MDCmdNotify and see if it still is crashing.


MDCmdNotify will not run before the restart and contains only two harmless commands:

2x COPY for the certificates for the ftp-server

and

POWERSHELL.EXE -command send-mailmessage -to xx@xx.de -from xx@xx.net -subject '"Lets Encrypt Notification, Managed Domain(s) created/renewed: %1 %2 %3 %4 %5"' -smtpserver mail.xx.net -body '"SSL-Zertifikate fuer folgende Managed Domain(s) wurden aktualisiert: %1 %2 %3 %4 %5"' -encoding ([System.Text.Encoding]::UTF8)

Maybe another hint: I use SSL on port 443 and 30443

During testing, I noticed another thing: Please look at the output of httpd.exe -t. Very Happy
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 551

PostPosted: Tue 28 Nov '17 13:32    Post subject: Reply with quote

You say: During testing, I noticed another thing: Please look at the output of httpd.exe -t.


Where should I look ?
Back to top
pbhq



Joined: 17 Mar 2013
Posts: 7
Location: Germany

PostPosted: Sun 10 Dec '17 20:05    Post subject: Reply with quote

admin wrote:
Where should I look ?


A good question: Since my last request, I see no more errors in the log file.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1