logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache 2 not responding

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
ratson



Joined: 19 Jan 2006
Posts: 2

PostPosted: Thu 19 Jan '06 11:58    Post subject: Apache 2 not responding Reply with quote

Hi there!

I've got some strange errors with apache2: first I've installed WAMP on my system (containing Apache 2.0.55) and MySQL just works fine, but apache cant answer to any queries. Apache service is up and running, no problems with it, port tests are showing apache.exe is listening on port 80 httpd.conf should be set properly, but when i am trying to reach localhost it does nothing, just waiting for answer... (acces.log remains empty, error.log contains no errors, no other errormessages) I removed WAMP, cleaned all the apache, wamp and other services and registry entries, then tried other packages with Apache2 (easyphp, appserv, ...) the problem still remained. I've tried to install WAMP to an other computer and it just worked fine on that. I ve all my firewalls turned off, have no internet connection on that computer so no skype, nor trilian an so on...(that would block port 80). After a few hours i just looked for my old EasyPHP 1.7 wich contains Apache 1 and it worked at once. So: Apache 1 is working fine, everything is all right, but i cannot get apache2 to work on this computer. Last day I've tried Apache 2.2 (with newest XAMPP package) the problem is still present.

I need php5 and apache2. do you have any idea what the cause can be? If you need any further informations about my config or somethin else i can give them... (I have WinXP SP2) I am totally disappointed... Sad


thanks in advance


RatSon
Back to top
ratson



Joined: 19 Jan 2006
Posts: 2

PostPosted: Mon 23 Jan '06 15:23    Post subject: solution Reply with quote

If you encounter problems running Apache 2 under Windows, such as corrupted or incomplete file downloads, unexplained error messages, or a conflict with a software firewall, please place the following directives in httpd.conf to see if they eliminate the issue:

EnableSendfile Off
EnableMMAP Off
Win32DisableAcceptEx

The general problem is that many people install various add-ons to windows (such as software firewalls, virus checkers, etc) that break some of the advanced functionality that Apache uses to speed the sending of files. The above directives turn off the advanced functionality and make Apache fall back to more basic (but slower) techniques.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1