logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



mod_aspdotnet binary for Apache 2.2

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
jd2066



Joined: 24 Jan 2006
Posts: 4

PostPosted: Wed 25 Jan '06 4:40    Post subject: mod_aspdotnet binary for Apache 2.2 Reply with quote

Hi,
Does anyone here know where I can find a mod_aspdotnet binary for Apache 2.2?
I've done a few google searches and couldn't find one.
Justin
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 01 Feb '06 11:06    Post subject: Reply with quote

Please have a look at http://httpd.apache.org/cli/introduction
Back to top
jd2066



Joined: 24 Jan 2006
Posts: 4

PostPosted: Wed 01 Feb '06 21:34    Post subject: Reply with quote

James Blond wrote:
Please have a look at http://httpd.apache.org/cli/introduction

I already tryed downloading that and installing it but Apache 2.2 failed to start when I had that in httpd.conf.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 02 Feb '06 1:06    Post subject: Reply with quote

Which error message did you get? tried apache -e debug ?
Back to top
jd2066



Joined: 24 Jan 2006
Posts: 4

PostPosted: Thu 02 Feb '06 1:36    Post subject: Reply with quote

James Blond wrote:
Which error message did you get? tried apache -e debug ?

I just tryed that and got the error message:
Quote:

httpd.exe: Syntax error on line 123 of D:/0Shared Services/Apache/conf/httpd.conf: Cannot load D:/0Shared Services/Apache/modules/mod_aspdotnet.so into server:
The specified module could not be found.

Which is odd as if I copy that path and paste it into the Windows run dialog it brings up what program do you want to run this dialog so that means it is the right path.

Edit:
The lines in httpd.conf are:
Quote:
LoadModule aspdotnet_module modules/mod_aspdotnet.so
AddHandler asp.net asax ascx ashx asmx aspx axd config cs csproj \
licx rem resources resx soap vb vbproj vsdisco webinfo
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Thu 02 Feb '06 11:42    Post subject: Reply with quote

RTFM *g* I found it in the manual, mod_aspdotnet.so is only for Apache 2.0.x ! Apache 2.2.x is not supportet yet. So you have to use the Apache 2.0 if you want to run mod_aspdotnet.so
Good luck!
Back to top
jd2066



Joined: 24 Jan 2006
Posts: 4

PostPosted: Fri 03 Feb '06 1:28    Post subject: Reply with quote

Ok.
I did have mod_aspdotnet running under Apache 2.0 before I upgraded to Apache 2.2.
For now I'm just using mod_proxy to IIS.
I had thought there a was a way to get it working with Apache 2.2 as both are listed at http://www.apachelounge.com/siteinfo.html
Justin
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Fri 03 Feb '06 14:35    Post subject: Reply with quote

James is right, Apache 2.2.x is not supportet yet. I tried to compile, no go.


jd2066 wrote:
I had thought there a was a way to get it working with Apache 2.2 as both are listed at http://www.apachelounge.com/siteinfo.html


Sorry, I am not clear on that page. I am using it proxying to an other Apache (2.055) install.

Steffen
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1