logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache doesn't run on Belkin at all

 
Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking



View previous topic :: View next topic  
Author Message
Helper_Solver



Joined: 30 Oct 2006
Posts: 10

PostPosted: Mon 30 Oct '06 17:43    Post subject: Apache doesn't run on Belkin at all Reply with quote

Hi All And Professionals At There,

I have apache installed and im trying to run it behind a Belkin Router. I have Port Forwarded the ports. It doesn't work to access it on the public IP but it works on the Network IP e.g. 192.168.2.x. But it works when i disable NAT or connect it directly to the MODEM. I have contacted Belkin and followed their steps but still nothing. Belkin cant even solve my problem. So im wondering if your professionals can solve it or is it just impossible to use Belkin for Apache. And oh ya, i have tried to disable the firewall on the belkin router but still nothing.

Belkin
Firmware Version
4.05.03
Boot Version
2.01.02
Hardware
F5D7231-4
Back to top
Jorge



Joined: 12 Mar 2006
Posts: 376
Location: Belgium

PostPosted: Mon 30 Oct '06 18:49    Post subject: Reply with quote

Try after a complete facotry restore (software first, then do a hardware reset)

I had that isseus it was something about remote management binding to port 80 bah. That solved ti for me. I ran apache through 3 belkins sofar no problem.
Back to top
Helper_Solver



Joined: 30 Oct 2006
Posts: 10

PostPosted: Thu 02 Nov '06 23:12    Post subject: Reply with quote

I tried that, belkin even told be to do that. But still nothing :S
Back to top
Brian



Joined: 21 Oct 2005
Posts: 209
Location: Puyallup, WA USA

PostPosted: Thu 02 Nov '06 23:30    Post subject: Reply with quote

Quote:
It doesn't work to access it on the public IP but it works on the Network IP e.g. 192.168.2.x

192.168 isn't a public IP, that is a private class C range.

So do you want your server accesible from the WAN?

If the answer is yes then if you connect your server directly to the modem, disable ALL firewalls, security monitoring crap, and run the system completely naked for the test, can you access your server from a WAN connection to the IP?

You can use a proxy such as http://babelfish.altavista.com or even better http://www.hidemyass.com and test if need be for a true WAN test.

Start with eliminating any possible issue, a direct naked unprotected connection to the internet and is the server reachable?

Next, add the router but turn OFF the firewall. You will now be on a local IP, like 192.168.x.x, you said that you can reach it with NAT off, so you should be able to again.

Next, try setting NAT, does it work?

Basically start from the beginning and work your way back in, that is how I found out where I was going wrong with my Zyxel firewall/router.
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Fri 03 Nov '06 0:05    Post subject: Reply with quote

I'm looking at the manual for your router, what do you have for the following settings under Firewall | Virtual server (a.k.a. - Port Forwarding):

Enable (check box) - checked or not
Description - __________
Inbound post ( ____ - ____ )
Type - TCP or UDP
Private IP address - ___
Private port ( _____ - _____ )

Next, what are you using a wired or wireless connection?

Are you using the router's DHCP server?

If you are using DHCP, does your currently assigned IP match that in (Port Forwarding)?
Back to top
Helper_Solver



Joined: 30 Oct 2006
Posts: 10

PostPosted: Wed 08 Nov '06 22:54    Post subject: Reply with quote

Hey guys,

DCHP Server : Enabled
Port forwarding ports: 8080/ 443.
Check Box: Ticked

And a Wireless Router : BELKIN

Plus guys, when i connect manually to the internet without NAT apache works on a public ip 213.xxx.xxx:8080 so that means apache is working fine but on the router it just isn't working.

So had this great idea, why not connect it manually from my PC and share my internet connection on my computer over wireless, so i would like be the server but i dont really know how to do this.
Back to top
Helper_Solver



Joined: 30 Oct 2006
Posts: 10

PostPosted: Wed 08 Nov '06 22:55    Post subject: Reply with quote

When i connect my internet manually, without a private ip e.g. 192.xxx or 10.xxx. just directly. So apache works great like that, just now i want to share my internet connection
Back to top
Brian



Joined: 21 Oct 2005
Posts: 209
Location: Puyallup, WA USA

PostPosted: Wed 08 Nov '06 23:35    Post subject: Reply with quote

Quote:
DCHP Server : Enabled
Port forwarding ports: 8080/ 443.


If you have DHCP enabled, how do you know which IP to port forward to?

I would think you would static the IP for you server, then you know where to forward traffic to 'cuase this sure appears to be a very simple routing issue on the surface...
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Thu 09 Nov '06 10:06    Post subject: Reply with quote

Brian is right about knowing which IP to forward to since you are using DHCP. You can use DHCP on the network, but the PC running the server is going to need a static IP so that Port Forwarding will work continually. Otherwise, when the IP Lease from DHCP expires your forwarding will die with it. I do not have a Belkin, but my router appears to operate in a similar fashion. I use an IP from the DHCP pool as a static IP (for the server), and then forward inbound request on Port 80 (443 and a few others) to the IP I take from the pool.
Back to top
Helper_Solver



Joined: 30 Oct 2006
Posts: 10

PostPosted: Fri 10 Nov '06 0:07    Post subject: Reply with quote

I do know which IP to port forward. Im already doing that. Im forwarding them to 192.168.2.2 (MY PRIVATE IP) and ports forwarded to 8080 and 443
Back to top
Brian



Joined: 21 Oct 2005
Posts: 209
Location: Puyallup, WA USA

PostPosted: Fri 10 Nov '06 0:14    Post subject: Reply with quote

Okay well without NAT you have no issues but with NAT you do.

We can safely assume the problem could be in NAT routing. So, maybe it just takes some time on the phone with Belkin? Do they offer tech support?

Personally, I do not know jack about Belkins, never used, owned or touched one. But really it's all semantics when it comes to the differences between how things get done, just as long as the router has the capabilities to do what you need it to do.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking
Page 1 of 1