logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



IIS proxy to Apache webserver

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
Jeremy777



Joined: 16 Mar 2006
Posts: 3
Location: Ottawa

PostPosted: Thu 16 Mar '06 22:55    Post subject: IIS proxy to Apache webserver Reply with quote

Hi All,
Im wondering if anyone can advise on the following issue..

I have an Apache 2x (win32) webserver on a machiene on our LAN.

In order to reach the apache server, http requests from WAN are directed through an IIS proxy.

This seems to work fine for simple html pages and also php generated pages. However Im having troubles getting WAN http access to function properly with a somwhat more complicated application (a web map server, "Mapserver") that is being served up by the Apache server. Access to the mapserver and eveything else works fine from within the LAN.

Can anyone tell me if there are any configuration issues I should be considering in this senario? Or any other issues that would be relavant to such a set up?

Thanks
Jeremy
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Fri 17 Mar '06 10:47    Post subject: Reply with quote

Normaly you can leave the configuration as it is. Only if you have specificated an IP you have to change it to the IP from the ISP or just don't set an IP

e.g.
Code:

#for an static IP
Listen 80.134.45.28:80

#set IP dynamic. This is the best solution only to set the Port
Listen 80


If you run PHP Apps users can access set in PHP.ini the open_basedir to the webroot i.e. C:/apache/htdocs so that users can't access the normal file system with PHP.
Back to top
Jeremy777



Joined: 16 Mar 2006
Posts: 3
Location: Ottawa

PostPosted: Fri 17 Mar '06 22:28    Post subject: Reply with quote

Thanks for the reply,
I have the IP set as dynamic. But it still chokes....
ANy futher thoughts?
Thanks
Jeremy
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sun 19 Mar '06 13:24    Post subject: Reply with quote

HostnameLookups Off This means the apache has not to resolve the IP adress to a name. Makes requests faster.

UseCanonicalName Off so the Apache uses the URL from the client, not from the given name.
Back to top
Jeremy777



Joined: 16 Mar 2006
Posts: 3
Location: Ottawa

PostPosted: Mon 20 Mar '06 16:15    Post subject: Reply with quote

Hi, Thanks again for the suggestion ... I have tried both of those and still no results. to further clarify my situation:
The part of my page that is not working is an image that is generated 'on-the-fly' by the mapserver. This image is called by a url such as http://myserver/cgi-bin/mapserver.exe?map=themapfile&status=on

I notice that when Im not behind my LAN, I cant reach the cgi-bin dir. I have created an alias for cgi-bin but it doesnt seem to work. Is there somthing in the apache conf file I should look at?

Thanks
Jeremy
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Mon 20 Mar '06 20:30    Post subject: Reply with quote

Give the viruall (alias) directority free?
ScriptAlias /cgi-bin/ path/to/cgi-bin/

<Directory "/path/to/cgi-bin">
Options Indexes MultiViews +ExecCGI
AllowOverride None
Order allow,deny
Allow from all
</Directory>
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1