logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



PDO extensions for Windows

 
Post new topic   Reply to topic    Apache Forum Index -> Coding & Scripting Corner



View previous topic :: View next topic  
Author Message
GeoffreyB



Joined: 09 Oct 2006
Posts: 12
Location: Mornington, Victoria, Australia

PostPosted: Mon 06 Nov '06 6:48    Post subject: PDO extensions for Windows Reply with quote

Does anyone know if there is a php_pdo_mysql.dll available that supports mySQL version 5.0.26?

I am trying to get my head around Zend Framework by working through a tutorial. It requires PDO support and the native php_pdo_mysql.dll only supports mySQL versions 3.x/4.x. I will downgrade mySQL if I have to but i'd rather not.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Mon 06 Nov '06 12:44    Post subject: Reply with quote

No, there is no php_pdo_mysql for MySQL 5.0.x
There is no need! Because the pdo interface if for supporting older databases when the new client from php_mysql und php_mysqli is for the version from MySQL 4.1 or greater.
I haven't worked with the Zend framework yet, but if that requires a downgrade, it is not up to date and you should rewrite the functions you need. Or better write your own.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Coding & Scripting Corner
Page 1 of 1