logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Can't start Apache 2.2 in XP

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
naya



Joined: 15 Dec 2005
Posts: 4

PostPosted: Thu 19 Jan '06 2:14    Post subject: Can't start Apache 2.2 in XP Reply with quote

If I type the following command in the DOS window:
httpd.exe -k start

Then I got error message:
httpd.exe: Syntax error on line 388 of E:/apache/Apache22/conf/httpd.conf: Cannot load E:/PHP/php5apache2.dll into server: The specified module could not be found.
But I have "php5apache2.dll" file in "e:/PHP/"

Any idea?

Thank you in advance.
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Thu 19 Jan '06 9:19    Post subject: Reply with quote

Where did you get your "php5apache2.dll"? From PHP.net or from the downloads here?

If you are using Apache 2.2.0 that Steffen built, then you need to use the PHP 5 module that is provided on the Downloads page - http://www.apachelounge.com/download/

Rather than explaining it over again, there are Post here that tell you why this is. In short, it it because the PHP module has to be built with the source code from the web server and version you intend to use - in this case Apache 2.2.0.

Hope this helps.
Back to top
naya



Joined: 15 Dec 2005
Posts: 4

PostPosted: Thu 19 Jan '06 18:25    Post subject: Reply with quote

Thank you.
Now it starts but after displaying warning message:Very HappyVery HappyVery Happy
PHP Startup: Unable to load dl 'e:\php\ext\php_mcrypt.dll' - The specified module could not be found.
If this is same problem, where could I find the module? It's not in the directory you posted.

Rolling Eyes
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 19 Jan '06 18:32    Post subject: Reply with quote

Nope, this looks like a php configuration issue.


Do you have: php_mcrypt.dll in e:\php\ext' ?

Steffen
Back to top
naya



Joined: 15 Dec 2005
Posts: 4

PostPosted: Thu 19 Jan '06 18:53    Post subject: Reply with quote

yes Rolling Eyes
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 19 Jan '06 19:34    Post subject: Reply with quote

Module: php_mcrypt.dll depends also on libmcrypt.dll , maybe it helps to copy this from you php folder to your c:/windows/ .

Which version of php are you running ?

Steffen
Back to top
naya



Joined: 15 Dec 2005
Posts: 4

PostPosted: Thu 19 Jan '06 20:15    Post subject: Reply with quote

Steffen,
thank you. Now it is working.
I installed php 512 because 511 doesn't have libmcrypt.dll.
Very Happy Very Happy Very Happy Very Happy Very Happy
Back to top
Leoandru



Joined: 02 Feb 2006
Posts: 2

PostPosted: Thu 02 Feb '06 21:39    Post subject: Reply with quote

I'm having the same problem, I got apache 2.2 and php 5.1.2 from the downloads page on this site. I follwed the instruction in the zip file but I still get the error:


"Syntax error on line 123 of E:/Program Files/Apache/conf/httpd.conf: Cann
ot load E:/Program Files/Apache/modules/php5apache2.dll into server: The specifi
ed module could not be found."

I check and double checked that the files are in the directory, I even tried to move them to a directory with no spaces and changed the http.conf accordingly with no luck. I'm banging my head against the wall trying to figure out why it won't work, I read all the post on this forum and it seems to work for everyone else.

Windows Xp SP2.
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Fri 03 Feb '06 8:37    Post subject: Reply with quote

Leoandru,

Quote:
"Syntax error on line 123 of E:/Program Files/Apache/conf/httpd.conf: Cannot load E:/Program Files/Apache/modules/php5apache2.dll into server: The specified module could not be found."


According to your posted Error Message - You have PHP trying to be LOADED from the folder:

E:/Program Files/Apache/modules/php5apache2.dll

Is this ACTUALLY the PATH to where PHP resides?

In the Apache conf file, what is your LoadModule directive for PHP?

Most people I know and converse with isolate PHP in separate folder away from the Apache tree...something like E:\PHP - such that the LoadModule directive is:

LoadModule php5_module "E:/php/php5apache2.dll"
Back to top
Leoandru



Joined: 02 Feb 2006
Posts: 2

PostPosted: Fri 03 Feb '06 21:09    Post subject: Reply with quote

Yeah I tried moving it to the modules folder and issued the directive

LoadModule /modules/php5apache2.dll

I also tried several other locations and changed the directive accordingly. Not of them worked. I reverted to an older version of apache and different php module cause that works ok for me with no problems. I guess I'll try again one day when time permits.
Back to top
leo-fan.aq



Joined: 25 Apr 2006
Posts: 1

PostPosted: Tue 25 Apr '06 11:54    Post subject: Reply with quote

Thank you very much,it works now! Very Happy
Back to top
juankasalas



Joined: 14 May 2006
Posts: 3

PostPosted: Sun 14 May '06 3:34    Post subject: 403 error Reply with quote

hi i do everything you say, first i have the error of the apache2.dll... i make that you said and works. but in the final the server send me a 403 error...

can help me please...

Juan Carlos
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1