logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



I doubt that anyone here can solve this problem, but...

 
Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking



View previous topic :: View next topic  
Author Message
worldveil



Joined: 12 Sep 2007
Posts: 5

PostPosted: Thu 13 Sep '07 0:25    Post subject: I doubt that anyone here can solve this problem, but... Reply with quote

Hi all,

I doubt that anyone here can solve this problem, or take the time to do so, but here goes...

This is my first server, and I simply cannot get it to work.

MY CONFIGURATION:


Speedstream 4200 DSL modem w/ethernet line to NETGEAR Wireless Router (WPN824). The router connects with CAT5 cable to my Windows XP server computer (which has the latest Apache and PHP). Wirelss signal is used for my other computer.

I am running Apache with no-ip as well. My site name is: "http://worldveil.hopto.org"

MY PROBLEM:

I have set up HTTP port forwarding in my modem (which for some reason acts as a router as well) to port 80, with my server address as 192.168.254.10 The problem is that I cannot connect to my web site within my network. My friend is able to view the website from his home.

I am not able to configure my NETGEAR router to accept the port forwarding of 192.168.254.10 because it isn't a "valid LAN address" --- but I can't configure my modem to use a different address either.

When I type in the address "http://worldveil.hopto.org" it takes me to my router login page -- WHY?.

If I haven't included enough info -- please tell me -- I can put some more up.

Thanks,
Will
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Thu 13 Sep '07 3:25    Post subject: Reply with quote

It seems like you should have three IP addresses here:
    Your external address to your modem 75.88.79.234 (aka worldveil.hopto.org)
    Your wireless router (I'm guessing this is 192.168.254.10, assigned by your DSL modem)
    Your XP server (this usually starts with 192.168.1.something) assigned by your WPN824
Code:

    outside world
          |
+------------------+
|  75.88.79.234    |
|      MODEM       |
| 192.168.254.254  |
+------------------+
          |
+------------------+
|  192.168.254.10  |
|      WPN824      |
|   192.168.1.1    |<------- other machines in your network
+------------------+
          |
+------------------+
|  192.168.1.???   |
|    XP/APACHE     |
+------------------+


This guess presumes:
    1. your modem is plugged into the Internet Port on your WPN824
    2. your XP server is plugged into one of the four LAN Ports on your WPN824
    3. your modem is set to forward port 80 to 192.168.254.10
    4. your WPN824 is set to forward port 80 to your XP server address 192.168.1.???
Obviously something is wrong with my guess, because just forwarding the modem to 192.168.254.10 doesn't seem like it could get your friend connected all the way through to your Apache server.

re "it takes me to my router login page" - Is that your modem login page or your WPN824 login page?

-tom-
Back to top
worldveil



Joined: 12 Sep 2007
Posts: 5

PostPosted: Thu 13 Sep '07 4:27    Post subject: Reply with quote

Yes, you are right on with most of your guesses. (The XP server computer is 192.168.1.3). Thank you so much for replying so quickly. It means a lot. Unfortunately, you are right about one thing -- this problem is deeper than forwarding, otherwise the server wouldn't be accessible from the internet.

I am going to try to answer some of your questions and give you some more information.

IP Addresses:

Default Gateway: 192.168.254.254
XP/Apache: 192.168.1.3
Speedstream 4200 Modem: 192.168.254.254
NETGEAR: 192.168.1.1
Server (forwarded on 80): 192.168.254.10


The 'default gateway' is set to (according to an ipconfig run) 192.168.1.1 (NETGEAR router) However, the 'default gateway' in the NETGEAR router page says that "gateway IP address" is 192.168.254.254 (modem)...

***To answer your question, the Speedstream modem page is the one I go to when I enter ("http://worldveil.hopto.org").

Static IP?

Also, my Network Connections is set to "obtain IP address automatically". I have tried to set it to a static IP, but it doesn't work. The router won't allow me to forward to the server with any IP that is ???.???.254.???

Unfortunately, this configuration (your diagram) is very complicated and I think that something is conflicting. I have this felling that I'm really close but that something very small is in the way.

Hoping someone will help,
Will
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Thu 13 Sep '07 5:21    Post subject: Reply with quote

re: "The router won't allow me to forward to the server with any IP that is ???.???.254.??? "

When you say "The router", if you mean the WPN824 - you want it to forward port 80 requests to 192.168.1.3 (the Apache server machine)
- not to 192.168.254.10 (the WPN824 itself).

Both the WPN824 and the Speedstream 4200 modem are routers, so "The router" is a little ambiguous.

I presume you can access your Apache server OK locally if you use http://192.168.1.3/ instead of http://worldveil.hopto.org. Is that correct?

re:"The 'default gateway' is set to (according to an ipconfig run) 192.168.1.1 (NETGEAR router) However, the 'default gateway' in the NETGEAR router page says that "gateway IP address" is 192.168.254.254 (modem)"
That all seems correct. The Apache machine reaches the outside world by connecting to 192.168.1.1. The WPN824 reaches the outside world by connecting to 192.168.254.254.

-tom-
Back to top
worldveil



Joined: 12 Sep 2007
Posts: 5

PostPosted: Fri 14 Sep '07 0:26    Post subject: Reply with quote

Yes, the NETGEAR router (192.168.1.1) is forwarding 80 to 192.168.1.3 on HTTP. You are right, the word 'router' is a little ambiguous in this case.

The reason I tried to set it up that way is that my modem-router won't let me forward to 192.168.1.3 on port 80...it says that "NAPT server IP address is not a valid host LAN address". I am a little unsure if this has to do with my WAN IP vs a different LAN IP. Why won't the modem-router let me forward to 192.168.1.3?


Server Access

I can access my server in Firefox by:

http://192.168.1.3/
http://192.168.254.10/
http://localhost/

--> worldveil.hopto.org still takes me to my router, presumably because the modem is forwarding to 192.168.254.10, but even that makes no sense at all. It is very strange that I can't access my site through worldveil.hopto.org, but that other people can...you can access it...right???

Port Forwarding:

These addresses show my port forwarding pages on both the NETGEAR and the modem.

NETGEAR router:
"http://cid-c0b17d42dfa381a9.skydrive.live.com/embedrowdetail.aspx/Will%20Drevo|4s%20Folders/netgear.bmp"

Speedstream 4200 Modem:
"http://cid-c0b17d42dfa381a9.skydrive.live.com/embedrowdetail.aspx/Will%20Drevo|4s%20Folders/speedstream.bmp"

***On the Speedstream page (above), I'm not sure what the ICMP rule is doing -- but it is forwarding to the modem -- which would explain how worldveil.hopto.org would go to the modem-router instead of the site. This is just a guess.

Thanks again for being patient. This thing is driving me to the brink of insanity.
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Fri 14 Sep '07 16:50    Post subject: Reply with quote

re: "Why won't the modem-router let me forward to 192.168.1.3?"
That makes sense. The modem cannot see any 192.168.1.* addresses on the local network side (bottom side) of the NETGEAR router.
The modem should forward port 80 to 192.168.254.10.
Only the NETGEAR router can forward to 192.168.1.* addresses.

Apparently your Speedstream modem considers any connection to port 80 which comes from the inside (from the bottom in the diagram) to be modem admin, regardless of its port-forwarding setting.

Unless you can switch the Speedstream modem to use a different port number for admin, your only choice may be to override the name lookup for worldveil.hopto.org in all your local machines. You can do this by adding a line to the file: \WINDOWS\System32\drivers\etc\hosts
Code:
192.168.1.3     worldveil.hopto.org
You would need to do this for every machine in your local network. Ugly - but I think it would work.

-tom-
Back to top
worldveil



Joined: 12 Sep 2007
Posts: 5

PostPosted: Sun 16 Sep '07 18:08    Post subject: Reply with quote

tdonovan, you got it. Modifying the system32 values overrode it and now it works.

I did this for all my local machines and it works like a charm.

Thanks again tdonovan -- you saved me a lot of headaches.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking
Page 1 of 1