logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.




apxs on win2k3

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Mon 10 Dec '07 9:02    Post subject: apxs on win2k3 Reply with quote

Hi,

I am trying to plugin amodule to apache on win2k3.
I used the apxs tool from this site executed configure.pl and got apxs.bat.

BUt when I run

C:\apache\bin>apxs.bat -c -i -a -Wc mod_test.c libhttpd.lib libapr-1.lib wsock32.lib

I got this error. I don't what is the problem with apxs.

mod_test.lo : fatal error LNK1112: module machine type 'IA64' conflicts with target machine type 'X86'
apxs:Error: Command failed with rc=5767168

see if somebody got this error.
Back to top
ashwani_ap



Joined: 29 Aug 2007
Posts: 47
Location: Bangalore

PostPosted: Mon 10 Dec '07 13:44    Post subject: Reply with quote

HI,

The issue is resolved.
apxs uses c1 copiler provided by visual studio.
I added the path for the right c1 compiler in the env variable.
It is working now.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1