logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



PHP 5.1.2 and MySQL 5.0.20

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
Mitron



Joined: 04 Jan 2006
Posts: 64

PostPosted: Sat 15 Apr '06 12:00    Post subject: PHP 5.1.2 and MySQL 5.0.20 Reply with quote

Ok, I hope this isn't off topic here but I was curious if there was a fix for the MySQL 5.0.19 and 5.0.20 showing up in phpinfo() as 5.0.18. I take it the reason is because the only PHP Connector for MySQL is the 5.0.18 version. I kinda asked this on MySQL forum but no reply. Just curious if I have a problem or if this is common due to them not releasing a connector for the more recent versions.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Sat 15 Apr '06 12:14    Post subject: Reply with quote

Be sure that you have libmySQL.dll of version 5.0.20 in your windows folder. Copy it from the .../mysql/bin folder to your windows and php folder.

Steffen
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sat 15 Apr '06 16:02    Post subject: Reply with quote

For portable Versions like on a USB Stick copy the libmySQL.dll in the apache/bin/ folder.
Back to top
Mitron



Joined: 04 Jan 2006
Posts: 64

PostPosted: Sat 15 Apr '06 20:32    Post subject: Reply with quote

Steffen wrote:
Be sure that you have libmySQL.dll of version 5.0.20 in your windows folder. Copy it from the .../mysql/bin folder to your windows and php folder.

Steffen


Thanks again Steffen. Smile I had already done that, but doing a search for that filename I found it also in winnt/system32. After deleting that file everything appears as it should. I must have put it there on the 5.0.18 install.
Back to top
Mitron



Joined: 04 Jan 2006
Posts: 64

PostPosted: Wed 19 Apr '06 10:28    Post subject: Reply with quote

BTW, I see they released a new PHP connector for MySQL 5.0.20 in case this is of interest to anyone. Smile

http://dev.mysql.com/downloads/connector/php/
Back to top
Millennium



Joined: 17 Apr 2006
Posts: 179
Location: Leiderdorp, NL, EU

PostPosted: Wed 19 Apr '06 21:44    Post subject: Reply with quote

Anybody got the new MySQLI Connector working ?
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1