logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Forum Register Log in  RSS Apache Lounge


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.




make_sock: could not bind to address 0.0.0.0:80 problem

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
victorlin



Joined: 13 Dec 2008
Posts: 1

PostPosted: Sat 13 Dec '08 6:43    Post subject: make_sock: could not bind to address 0.0.0.0:80 problem Reply with quote

Hi,

I encounter a very strange problem when I start apache server.

I got this error message:
Quote:
(OS 10048)一次只能用一個通訊端位址 (通訊協定/網路位址/連接埠)。 : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


Normally, it would appear when there is some program is using port 80. I have checked by using netstat -ab, but I found no program is using port 80. And I try to start another server that use 80 port, it works! It indicate there is nobody is using port 80, so why apache tell me someone is using it?

This problem could be solved by reboot computer, but however, this problem will appear after a while.

How could I fix that problem? Could someone help me?

Thanks.

Victor Lin.
Back to top
diazjavier



Joined: 30 Dec 2008
Posts: 1

PostPosted: Tue 30 Dec '08 6:27    Post subject: Solution Reply with quote

Try comment this line in /etc/apache2/httpd.conf file (put # before):

Listen 80

I hope to be usefull

(sorry for my english)
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 5013
Location: Germany, Next to Hamburg

PostPosted: Tue 30 Dec '08 10:52    Post subject: Reply with quote

I think your firewalls blocks your apache. You can try disable it and looks if that works.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1