logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



[HELP] Apache Port Forwarding

 
Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking



View previous topic :: View next topic  
Author Message
Raph



Joined: 19 Oct 2009
Posts: 2

PostPosted: Mon 19 Oct '09 22:43    Post subject: [HELP] Apache Port Forwarding Reply with quote

Hey there guys, how is everyone doing?

Ok, so here is my problem. I'm trying to run a webserver on my computer, so I can host a web site which I have done before, just not on this computer. This is what is happening:
Every time I run apache everything goes OK, and if I try to connect to my website locally, everything works like it should, now if I try to connect to my website from a computer outside my network, I get my router login page every time. I have tried port forwarding it many times, using port 80 and 443, but the result is always the same, I end up in my routers login web page. Does anyone have any idea why this is happening? Any comments/ideas are welcome, and thank you for taking the time to read this.

Truly,
~Raph
Back to top
paranid



Joined: 02 Mar 2009
Posts: 11

PostPosted: Tue 20 Oct '09 13:15    Post subject: Reply with quote

Hi,
I assume you are using NAT and your server has IP address from private network range.

Does your router use the same port 80/443 for its web interface? If so, try to change it (e.g. 80 -> 81, remember that port to be able to configure your router Smile). Port forwarding should work now.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Tue 20 Oct '09 13:57    Post subject: Reply with quote

Hi Raph,
which router do you use?
Back to top
bentogoa



Joined: 09 Feb 2007
Posts: 66
Location: GOA

PostPosted: Tue 20 Oct '09 17:11    Post subject: Reply with quote

Change the router port to 81 or something else

For most Dlink router this setting is found at Tools > WebPort
Back to top
Raph



Joined: 19 Oct 2009
Posts: 2

PostPosted: Tue 20 Oct '09 20:06    Post subject: Reply with quote

Thanks for all the replies guys! What was happenign was, my router uses port 80 for its remote log in, so everytime I used my IP it automatically redirected me to the log in web page. Thanks for all the help guys!

PS: I use a Belkin F5d8230-4 For future reference if anyone ever has this problem.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking
Page 1 of 1