logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



v2.2.2 - Syntax Error re: php4apache2.dl

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
jsabarese



Joined: 19 May 2006
Posts: 8

PostPosted: Fri 19 May '06 17:29    Post subject: v2.2.2 - Syntax Error re: php4apache2.dl Reply with quote

i obviously have something wrong w/ my setup because apache2.2.2 won't start-- seems to be a php problem. (why am i installing php4.x? because that's what my hosting provider uses).

One unusual variable in the mix here:
Before installing Apache2.2.2, i had installed and used CFMX 7 (coldfusion), using it's built-in development server. if anyone has experience w/ this, please speak up. I have mapped the jrun from CFMX to Apache's htdocs in the past, and effectively processed coldfusion pages being served by Apache. no big deal-- works fine. pretty cool!

but, this time-- i wasn't planning to do that. didn't need to, although i believe i still have that option if i wish (perhaps that's the solution? i hadn't though of...). i honestly don't know if the ColdFusion server in this box has any effect on Apache and PHP before / after / during work, but i do know i'm getting a

Syntax Error (paraphrased): Apache can not start because you have a syntax error on line 487 of httpd.conf. Can not find "c:/php/php4apache2.dll" , yet i'm either seeing things, or the file is in fact present. i've tried reversing the slashes, i've tried w/ and w/out quotes. i've re-extracted the archive. nothing seems to work. i've checked the php.net manual installation proceedure, but following it to the letter leaves me in the same position.

anyone recognize this situation and know what i should do?

thanks so much for reading! i look forward to your reply.
-js
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Fri 19 May '06 17:40    Post subject: Reply with quote

Do you use the php4apache2.dll from the download page here ? The one shipped with php does not work with Apache 2.2.2


Steffen
Back to top
jsabarese



Joined: 19 May 2006
Posts: 8

PostPosted: Fri 19 May '06 19:09    Post subject: Reply with quote

no. i did not know that! where is that information posted?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Fri 19 May '06 19:16    Post subject: Reply with quote

In the PHP manuals you can see, that PHP only support Apache 1.3.x and Apache 2.0.x Wink
To run PHP with Apache 2.2.x you need this dll
Back to top
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Fri 19 May '06 19:44    Post subject: Reply with quote

On this Web:

Left naviation [Home].

Once there, Right naviagtion (about half was down) - it says Downloads...

Click ANY of those links.

or

just click here - http://www.apachelounge.com/download/
..
.
Back to top
jsabarese



Joined: 19 May 2006
Posts: 8

PostPosted: Fri 19 May '06 21:16    Post subject: Reply with quote

cool deal, guys. i got it as soon as i heard word of the proper mod, etc. worked like a charm. very cool.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1