logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Install Instructions Apache223, Php520, MySql5027 (update)

 
Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips



View previous topic :: View next topic  
Author Message
pips



Joined: 03 May 2006
Posts: 65
Location: Manchester, UK

PostPosted: Mon 22 May '06 12:34    Post subject: Install Instructions Apache223, Php520, MySql5027 (update) Reply with quote

Various threads exist in this forum regarding error messages etc when trying to install Apache 222, Php 514 & MySql 5021.
I myself experienced problems to start with, and with Steffen's help I've now got a fully working web server.

I have compiled some step-by-step instructions which I use all the time when installing webservers, and so far so good.

If you want to download a copy, feel free to do so http://www.adcommcepts.com/apache/wamp-install.pdf

I have just performed a clean install of Windows XP SP2, with all available service packs installed from Windows Updates and the instructions worked first time Smile didn't need to install the VC++ executable that Steffen mentions in some of his posts - although if you still have problems when you have followed my PDF, you may find that installing the VC++ executable will solve the problem.

Hope this helps,

Phil.

Admin note:
If you still have issues or find something confusing, please post in one of the other forums


Last edited by pips on Tue 13 Feb '07 2:23; edited 2 times in total
Back to top
pips



Joined: 03 May 2006
Posts: 65
Location: Manchester, UK

PostPosted: Sun 03 Dec '06 3:20    Post subject: Reply with quote

I've just updated my initial instructions to the latest versions (Apache 2.2.3, MySQL 5.0.27 and Php 5.2.0), along with a guide to adding SSL certificates and a couple of other mods too.
You can download it from here:- http://www.adcommcepts.com/apache/wamp-install-ssl.zip
In the zip file is the PDF instructions, along with two example CONF files.

Sorry the update has taken so long in coming, I've been busy with some other projects...... Hopefully won't leave future ones so long.

Phil.


Last edited by pips on Tue 13 Feb '07 2:22; edited 1 time in total
Back to top
frogsmack



Joined: 05 Dec 2006
Posts: 2
Location: Wirral

PostPosted: Tue 05 Dec '06 12:29    Post subject: Just to add Reply with quote

Thanks for the tutorial.
I’ll just add a few points for those with any difficulties;
PHP now suggests that you try and keep all of its files together in the one PHP folder instead of spreading them out to, for example, php.ini into c:\windows. This has many benefits, as php.net will tell you, including easier upgrade and file management. Your system has to be ‘told’ where to look for these files, set this in your system path. (Right click My Computer -> Properties ->Advanced ->Environment Variables->System Variables->Path->Edit add without quotes ‘;c:\yourPhpFolder’ ->OK->Restart your machine)

When PHP is looking for your php.ini it goes through a list of folders to find it, in the above tutorial this address is set with the System Variable ‘PHPRC’, change this to your PHP folder too. Remember you must restart your machine before this will take effect. To find out where your PHP install is looking for its php.ini file:

-Create a file in your apache htdocs called info.php
-Add the content;
<?php
phpinfo();
?>
-save file
-view through your browser (localhost/info.php)

The line: ‘Configuration File (php.ini) Path’ should result in ‘c:\yourPhpFolder\php.ini’, if it just says ‘c:\yourPhpFolder’ or ‘c:\windows’ it hasn’t loaded the php.ini file correctly.

One of the biggest problems not loading your php.ini file creates is to tell you ‘MySQL Extension isn’t loaded’ and so you spend days playing with MySQL and php.ini to fix it, when in fact your php.ini file, and its settings, aren’t being loaded at all.

I hope this helps,

FrogSmack
Back to top
pips



Joined: 03 May 2006
Posts: 65
Location: Manchester, UK

PostPosted: Tue 05 Dec '06 16:44    Post subject: Re: Just to add Reply with quote

Nice one frogsmack! That certainly makes sense!
Will revise the tutorial shortly.
Cheers,
Phil
Back to top
frogsmack



Joined: 05 Dec 2006
Posts: 2
Location: Wirral

PostPosted: Fri 08 Dec '06 12:38    Post subject: PHP Include files Reply with quote

Just a quick add...

When you edit your httpd.conf file in Apache\conf to add the fact apahe should use PHP to process all .php extention files:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:\PHP\"
LoadModule php5_module "C:\PHP\php5apache2_2.dll"
AddType application/x-httpd-php .php
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

make sure you add .inc files (remember to restart your apache service after httpd.conf changes):

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:\PHP\"
LoadModule php5_module "C:\PHP\php5apache2_2.dll"
AddType application/x-httpd-php .php .inc
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

This makes sure all your php include files get processed to and don't get displayed as text for all th world to see, i.e.:

- Make and include file in your apache webroot (htdocs), hello.inc
- Add content, <?php $hello = 'hello'; ?>
- Open in browser, localhost/hello.inc

If the page is blank = success, if you see the source = bad.

Hope it helps.
Back to top
ckasprzak



Joined: 03 Jan 2007
Posts: 1
Location: Buffalo, NY

PostPosted: Wed 03 Jan '07 2:12    Post subject: Reply with quote

Quick question, do you have to use all these 3rd party compiled version so that you can get a wamp solution or can you use the files from php.net apache.org and mysql.com ?
Back to top
pips



Joined: 03 May 2006
Posts: 65
Location: Manchester, UK

PostPosted: Wed 03 Jan '07 12:45    Post subject: Reply with quote

Although I haven't test the wamp server using the Apache software direct from apache.org - I don't see any reason why it won't work.
The MySQL and PHP are straight from the respective organisations.
Cheers,
Phil.
Back to top
jow



Joined: 05 Jan 2007
Posts: 3
Location: Boston, MA

PostPosted: Fri 05 Jan '07 20:43    Post subject: Reply with quote

Frogsmack - this is precisely the problem I'm having. I've followed your instructions (and read the tutorials on this site). Nothing I do seems to affect where php thinks php.ini is.

Running php 5.2, Apache 2.2.3 on Windows 2003 Server

%PATH% starts with c:\php;...
httpd.conf contains "PHPIniDir c:/php"

etc.

But phpinfo() ALWAYS seems to return php.ini found in c:\WINDOWS.

Any other ideas?


ckasprzak wrote:

The line: ‘Configuration File (php.ini) Path’ should result in ‘c:\yourPhpFolder\php.ini’, if it just says ‘c:\yourPhpFolder’ or ‘c:\windows’ it hasn’t loaded the php.ini file correctly.

One of the biggest problems not loading your php.ini file creates is to tell you ‘MySQL Extension isn’t loaded’ and so you spend days playing with MySQL and php.ini to fix it, when in fact your php.ini file, and its settings, aren’t being loaded at all.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Fri 05 Jan '07 23:51    Post subject: Reply with quote

Try to set the path in quotes that worked for me on w2k3 standart edtion (german)

Code:

PHPIniDir "C:/server2/php"
Back to top
jow



Joined: 05 Jan 2007
Posts: 3
Location: Boston, MA

PostPosted: Sat 06 Jan '07 0:02    Post subject: Reply with quote

I've tried that. As well as replacing "/" with "\". No difference.
phpinfo() replies it found PHP Ini in C:\WINDOWS if I put the PHPIniDir directive there AND if I don't. In other words, Apache seems to be ignoring this directive.

This is PHP 5.0 downloaded from www.php.net
And Apache 2.2.3
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Sat 06 Jan '07 0:23    Post subject: Reply with quote

in the worsest case place your php,ini in C:\Windows Confused
Back to top
jow



Joined: 05 Jan 2007
Posts: 3
Location: Boston, MA

PostPosted: Sat 06 Jan '07 5:04    Post subject: Reply with quote

Ah, well, that's the REALLY strange thing. I did try placing it in C:\WINDOWS but it was still not found. I know this because I have a page that produces the output of phpinfo() and it tells me what modules have been loaded. My php.ini loads php_mssql, which is commented out by default. Regardless of where I put php.info - even in C:\WINDOWS - I can never get phpinfo() to report that it has loaded php_mssql.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips
Page 1 of 1