logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



apachestats error perl mrtg.pl

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Webmaster Tools & Utilities



View previous topic :: View next topic  
Author Message
gich14



Joined: 08 Dec 2010
Posts: 1

PostPosted: Wed 08 Dec '10 16:21    Post subject: apachestats error perl mrtg.pl Reply with quote

Hey,

I'm trying to install apachestats but the following error occurs .. :

Code:

[xxxx:userxx][apachestats/bin] perl mrtg.pl
Bareword "P_DETACH" not allowed while "strict subs" in use at apachestats/bin\..\lib\mrtg2/MRTG_lib.pm line 1181.
Compilation failed in require at mrtg.pl line 89.
BEGIN failed--compilation aborted at mrtg.pl line 89.


Someone have an idea ?
google doesn't say lot ..

thx
gIch
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2574
Location: Hilversum, NL, EU

PostPosted: Wed 08 Dec '10 16:29    Post subject: Reply with quote

Seems you use a newer Perl version.

Coming days I shall upgrade MRTG.

The change log of a new version says:

From: Tobi
* fix "P_DETACH" and Pod::Usage issues with perl 5.12

Steffen
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2574
Location: Hilversum, NL, EU

PostPosted: Wed 08 Dec '10 20:56    Post subject: Reply with quote

Upgraded, please try the new download.

Steffen
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Webmaster Tools & Utilities
Page 1 of 1