logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



Apache 2.4 randomly stop responding [Solved]
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
admin
Site Admin


Joined: 15 Oct 2005
Posts: 515

PostPosted: Wed 22 Feb '12 18:31    Post subject: Reply with quote

I see now.

Try:

AcceptFilter http none
EnableSendfile Off
EnableMMAP off

That solves hick ups.

Btw. this Accepfilter has for SSL the well known issue, with http it is ok.
Back to top
DigitalDJ



Joined: 26 Mar 2006
Posts: 10

PostPosted: Wed 22 Feb '12 19:37    Post subject: Reply with quote

Hmm. I do recall having those directives in my Apache2.2 conf, but they aren't in my 2.4. This looks promising!
Back to top
bagu



Joined: 06 Jan 2011
Posts: 98
Location: France

PostPosted: Wed 22 Feb '12 19:40    Post subject: Reply with quote

I already have :
EnableSendfile Off
EnableMMAP off

I will try :
AcceptFilter http none

But where may i put it ? in httpd.conf ?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2474
Location: Hilversum, NL, EU

PostPosted: Wed 22 Feb '12 20:10    Post subject: Reply with quote

Good place is at the top of your httpd.conf


Steffen
Back to top
DigitalDJ



Joined: 26 Mar 2006
Posts: 10

PostPosted: Wed 22 Feb '12 21:09    Post subject: Reply with quote

Looks like my server is fixed. Many thanks!
Back to top
bagu



Joined: 06 Jan 2011
Posts: 98
Location: France

PostPosted: Wed 22 Feb '12 21:32    Post subject: Reply with quote

No more problem here too Wink

Thanks again.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2474
Location: Hilversum, NL, EU

PostPosted: Wed 22 Feb '12 21:39    Post subject: Reply with quote

Thanks you all.

Please keep an eye how 2.4.1 goes, and post issues and positive things here.

Steffen
Back to top
traxxus



Joined: 27 Feb 2012
Posts: 1
Location: Switzerland

PostPosted: Mon 27 Feb '12 17:40    Post subject: Reply with quote

Hi

My webserver with apache 2.4.1 (Windows Server 2003 32bit) has also hick-ups, exactly like descriped bythe other users. With the anti-hick-up lines from admin the bug is gone.
Back to top
sceptre



Joined: 30 May 2012
Posts: 1

PostPosted: Wed 30 May '12 13:58    Post subject: Reply with quote

I experienced the same issue. Apache 2.4 would stop responding after a few page refreshes.
I added "AcceptFilter http none" and it has been running fine all day.

Thanks!

Edit: Windows 2008 R1 32bit
Edit2: Not entirely fixed. Apache does not hang/lock anymore but will now crash and restart during heavy PHP+MySQL usage. Will try to track this down and maybe open a new thread about the issue.
Back to top
davelee53



Joined: 05 Dec 2012
Posts: 1
Location: USA, boston

PostPosted: Wed 05 Dec '12 15:33    Post subject: Apache 2.4 child process exited and restarted Reply with quote

Hi, I have the same issue after upgraded to Apache 2.4.3. I applied the proposed solution and added the following directives:

AcceptFilter http none
EnableSendfile Off
EnableMMAP off

but that didn't seem to help.

After some poking around in my web site, here are what I found:
1. It breaks only in the pages that their URIs need to be re-written using ScriptAliasMatch.
For example, I have the following page that is current broken.
http://myserver/ cgi-bin/nhSWeb?abc=xyz

Also, I have this ScriptAliasMatch that matches nhSWeb to nhWeb.
ScriptAliasMatch ^/(cgi|cgi-bin)/nhSWeb(.*) "C:/myServer/web/cgi-bin/nhWeb.exe$2"

2. This page is protected and required authentication. And if I hit this page directly, I am supposed to get the authentication. But with Apache v2.4.3, it didn't challenge me, it (child process) just exited out and restarted itself.

3. If I change the URL to http://myserver/ cgi-bin/nhWeb?abc=xyz (bypass the process of this ScriptAliasMatch) I then got the challenge, and after authentication, the page would render properly.

Any pointer you can share with us that would be truly appreciated.

thanks,
dave
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2474
Location: Hilversum, NL, EU

PostPosted: Wed 05 Dec '12 20:33    Post subject: Reply with quote

Looks you hit a bug.

Have a read at http://httpd.apache.org/bug_report.html .
Back to top
dosmac



Joined: 06 Dec 2012
Posts: 2
Location: United States, Albany

PostPosted: Thu 06 Dec '12 14:47    Post subject: My experiences Reply with quote

I've always had a problem with newer Apache servers 2.4.2 with speed and crashing across 5 or so servers.

Errors are mainly ONLY
[mpm_winnt:warn] (OS 64)The specified network name is no longer available. :winnt_accept: Asynchronous AcceptEx failed.

and occasionally

[mpm_winnt:error] Server ran out of threads to serve requests. Consider raising the ThreadsPerChild setting


I have set in my httpd.conf:

TraceEnable off
EnableMMAP off
EnableSendfile Off
ThreadsPerChild 100

With no change, and:

AcceptFilter http none
<IfDefine AEX>
Win32DisableAcceptEx
</IfDefine>

Together seems to have stopped the crashing. I would like to note my download speeds without crashing are STILL atrocious, at best. IIS pulls well over 1MB/s fluttering down to 600KB/s and Apache pulls 600KB/s and down to 10KB/s and stalls over and over.

Just a note: enablesendfile ON doesnt change anything Smile

Windows firewall seems to be the culprit with the IIS download speeds, but has NO effect with apache's speed??

With windows firewall OFF IIS is 1.9MB/s+ STEADY
and Apache is 600KB/s down to 10KB/s within a few seconds.



The First is what IIS/Apache do with win firewall ON, and second when you see 1.9MB/s steady it's with IIS and Win Firewall OFF. Apache remains like the first part of the picture with win firewall ON/OFF.
My servers are Win Server 2003 (x86+x64) both have this issue.


I have tried messing with "ThreadStackSize" "SendBufferSize" or "ReceiveBufferSize" and it results in the apacheserver hanging. I tried to modify the values in my registry for "SendBufferSize/ReceiveBufferSize" and it crashes the server so that's a no-go. Also tried disabling compression/gzip, and nothing changes. Other than this is a definite problem within the Apache code itself, I'm at a loss.


Last edited by dosmac on Fri 07 Dec '12 12:19; edited 1 time in total
Back to top
bagu



Joined: 06 Jan 2011
Posts: 98
Location: France

PostPosted: Thu 06 Dec '12 18:16    Post subject: Reply with quote

I've done a speed test with 1Go file apache 2.4.3

The average speed is (for me) 5Mo/S.
I'm on Windows 7 64bits Pro.

TraceEnable off
AcceptFilter http none
AcceptFilter https none
EnableMMAP off
EnableSendfile off

Mpm module loaded with the following config :
<IfModule mpm_winnt_module>
ThreadsPerChild 150
MaxConnectionsPerChild 0
</IfModule>

On my network, no QoS and no Vlans (there is an issue when vlan is on, the router, an asus rt-n16, can't handle the load and the speed drop down)
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6128
Location: Germany, Next to Hamburg

PostPosted: Fri 14 Dec '12 12:13    Post subject: Reply with quote

bagu wrote:

On my network, no QoS and no Vlans


Apache does not support QoS. Is it recommend to turn it off. So that is a good choise.

@dosmac you should disable QoS if it is enabled.
Back to top
dosmac



Joined: 06 Dec 2012
Posts: 2
Location: United States, Albany

PostPosted: Mon 17 Dec '12 12:14    Post subject: Reply with quote

Thanks for the suggestion of QoS off. It was turned on for some reason but I disabled it. The problem still exists. Speed bounces between 20KB/s and 250KB/s. Nowhere near the 2MB/s it should be from what IIS can do.
Back to top
idrusa



Joined: 15 Jan 2017
Posts: 1
Location: Otranto - Italy

PostPosted: Sun 22 Jan '17 13:13    Post subject: Reply with quote

Ok solved as suggested
thank you
but please put it as default next !

admin wrote:
I see now.

Try:

AcceptFilter http none
EnableSendfile Off
EnableMMAP off

That solves hick ups.

Btw. this Accepfilter has for SSL the well known issue, with http it is ok.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Goto page Previous  1, 2
Page 2 of 2