logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Forum Register Log in  RSS Apache Lounge


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.




Apache2.4+php5.4 error
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Tue 06 Mar '12 7:28    Post subject: Apache2.4+php5.4 error Reply with quote

Steffen wrote:
The modules php5apache2_4.dll handlers for Apache 2.4 with PHP version 5.4, 5.3 and 5.2 now available.


Works only with Win32 Apache 2.4.1+.


Steffen

apache2.4+php5.4 error
when i start my apache2.4,it said "httpd:Syntax error on line 123 of c:\apache24\modules\php5apache2_4.dll into server" and exit;
but it run well with php5.3.8
my system is windows xp sp2
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Tue 06 Mar '12 8:07    Post subject: Reply with quote

You say ...run well with php5.3.8... is that with Apache 2.4.1 ?

Sure you use the .dll and PHP 5.4 TS, double check ?

What are are PHP lines in your http.conf ?


Steffen

btw. We do not support XP SP2, SP3 is the minimum.
Back to top
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Wed 07 Mar '12 7:04    Post subject: Reply with quote

yes.it run well with php5.3.8

here are some pictures.
[img]r:/112.gif[/img]
[img]r:/113.gif[/img][/quote]
Back to top
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Wed 07 Mar '12 7:04    Post subject: Reply with quote

my system is windows xp sp3,how can i paste pictures in it?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 4948
Location: Germany, Next to Hamburg

PostPosted: Wed 07 Mar '12 18:19    Post subject: Reply with quote

yangshaoxing wrote:
how can i paste pictures in it?


Well you tried your localharddisc (r:/112.gif). That will not work. Use an image hoster like http://imageshack.us/ and than put the url to that picture between the img BB-tags
Back to top
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Thu 08 Mar '12 6:48    Post subject: Reply with quote

thanks.here are some pictures in my system.but why the title is php5.3.8,and the configure is php5.3.10?

http://219.137.26.116:1234/112.gif
http://219.137.26.116:1234/113.gif
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Thu 08 Mar '12 11:50    Post subject: Reply with quote

Looks like you are running php 5.3.8 and the handler is build against 5.3.10.

No problem, no API changes in 5.3.10 over 5.3.8.


Steffen
Back to top
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Fri 09 Mar '12 7:00    Post subject: Reply with quote

Steffen wrote:
Looks like you are running php 5.3.8 and the handler is build against 5.3.10.

No problem, no API changes in 5.3.10 over 5.3.8.


Steffen

but why apache2.4.1+php5.4 error?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Fri 09 Mar '12 8:25    Post subject: Reply with quote

Any in the php log, apache log or windows even viewer ?

Be sure:

- you using the correct handler from php5apache2_4.dll-php-5.4-win32.zip

- Using 5.4 TS

- you have no 5.3 extensions in /ext

Steffen
Back to top
yangshaoxing



Joined: 08 Jul 2010
Posts: 23

PostPosted: Tue 13 Mar '12 7:28    Post subject: Reply with quote

Steffen wrote:
Any in the php log, apache log or windows even viewer ?

Be sure:

- you using the correct handler from php5apache2_4.dll-php-5.4-win32.zip

- Using 5.4 TS

- you have no 5.3 extensions in /ext

Steffen

there is nothing message in log or even viewer
the error message in window like 'httpd: Syntax error on line 172 of C:/Apache24/conf/httpd.conf: Cannot load C:/Apache24/modules/php5apache2_4.dll into server: The specified procedure could not be found.'
btw. if i add a ";" before "extension" in php.ini,the error resume.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Tue 13 Mar '12 11:59    Post subject: Reply with quote

The error you get is: Cannot load C:/Apache24/modules/php5apache2_4.dll

The dll should not be copied to the Apache modules folder, but to your PHP folder.

From the ReadMe:


# Install:

- Copy php5apache2_4.dll to your php folder (eg. c:/php)

# Add to your httpd.conf

LoadModule php5_module "c:/php/php5apache2_4.dll"
AddHandler application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"


Steffen
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Mon 02 Apr '12 21:47    Post subject: Reply with quote

Steffen wrote:
The error you get is: Cannot load C:/Apache24/modules/php5apache2_4.dll

The dll should not be copied to the Apache modules folder, but to your PHP folder.

From the ReadMe:


# Install:

- Copy php5apache2_4.dll to your php folder (eg. c:/php)

# Add to your httpd.conf

LoadModule php5_module "c:/php/php5apache2_4.dll"
AddHandler application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"


Steffen


Call me a lamebrain, but is this just for Windows 7 or should it work on Windows XP SP3? I have spent way too many hours on this upgrade.

I'd like to have:

Windows XP (32) (new install) w / SP3
Apache 2.4.1
PHP 5.4

Is this even possible?
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Mon 02 Apr '12 22:10    Post subject: Reply with quote

BTW: I am getting the exact same error message ...

"C:/Apache24/conf/httpd.conf: Cannot load C:/php/php5apache2_4.dll into server: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

If someone could just tell me what versions of each I have to use, I'd do that instead. Thanks in advance
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Mon 02 Apr '12 22:24    Post subject: Reply with quote

Yep should work on XP.

Any in the php log, apache log or windows event viewer ?

Be sure:

- you using the correct handler from php5apache2_4.dll-php-5.4-win32.zip

- Using 5.4 TS


Steffen
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Mon 02 Apr '12 23:21    Post subject: Reply with quote

Steffen wrote:
Yep should work on XP.

Any in the php log, apache log or windows event viewer ?

Be sure:

- you using the correct handler from php5apache2_4.dll-php-5.4-win32.zip

- Using 5.4 TS


Steffen


Yes I installed php-5.4.0-Win32-VC9-x86.zip and php5apache2_4.dll-php-5.4-win32.zip
I'm not getting anything in the php log

Windows events:

Generate Activation Context failed for C:\php\php5apache2_4.dll. Reference error message: The operation completed successfully.

Dependent Assembly Microsoft.VC90.CRT could not be found and Last Error was The referenced assembly is not installed on your system.

Resolve Partial Assembly failed for Microsoft.VC90.CRT. Reference error message: The referenced assembly is not installed on your system.

The Apache2.4 service terminated with service-specific error 1 (0x1).


I did install the Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) from http://www.microsoft.com/download/en/details.aspx?id=8328
Does this include Dependent Assembly Microsoft.VC90.CRT?
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Mon 02 Apr '12 23:59    Post subject: Reply with quote

I found this information:

http://www.ekoob.com/how-to-fix-xampp-apache-error-side-by-side-configuration-is-incorrect-10781/

Quote:
It said something about microsoft VC9. I tried to find what version they used to compile it. I found it in readme_en.txt under c:\xampp. PHP was complied in VC9 X86 32bit thread safe.

As server was missing runtime components of Microsoft Visual C++ (VC9), It gave that error. It can be fixed by installing Visual C++ redistributable package.

If your server is 32 bit, Install Microsoft Visual C++ 2008 Redistributable Package (x86)


http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=29

I will try this tomorrow when I return to work
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 379

PostPosted: Tue 03 Apr '12 6:54    Post subject: Reply with quote

Yes, you need VC9 runtime to run php, it is clearly stated on the php.net windows download page.

Steffen
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Tue 03 Apr '12 15:04    Post subject: Reply with quote

I installed it and the other errors stopped but I am still getting ...

The Apache2.4 service terminated with service-specific error 1 (0x1).

... and Apache fails to load
Back to top
Cerebus



Joined: 02 Apr 2012
Posts: 8

PostPosted: Tue 03 Apr '12 15:11    Post subject: Reply with quote

and I still get ...

"C:/Apache24/conf/httpd.conf: Cannot load C:/php/php5apache2_4.dll into server: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

Has anyone been successful running Apache 2.4.1 and PHP 5.4 on a Windows XP machine?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2134
Location: Hilversum, NL, EU

PostPosted: Tue 03 Apr '12 18:49    Post subject: Reply with quote

What is now in the php log, apache log or windows event viewer ?

Steffen
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software Goto page 1, 2  Next
Page 1 of 2