logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Forum Register Log in  RSS Apache Lounge



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



mod_jk 1.2.35 from apache.org with apache 2.4.1

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
mwu



Joined: 25 Mar 2012
Posts: 11

PostPosted: Sun 25 Mar '12 18:35    Post subject: mod_jk 1.2.35 from apache.org with apache 2.4.1 Reply with quote

Hi

I want to use mod_jk 1.3.35 module for apache 2.4.x from apache.org, with the win32 apache 2.4.1 from apachelounge.com.

Unfortunately, this error occures:
Module ".\\mod_jk.c" is not compatible with this version of Apache (found 20120109, need 20120211)

Will apacheloung.com provide a compatible mod_jk module?

I know, I could also use proxy_ajp, instead of mod_jk.
But I have good experiences with mod_jk...

rg
Michael
Back to top
tdonovan
Moderator


Joined: 17 Dec 2005
Posts: 610
Location: Milford, MA, USA

PostPosted: Mon 26 Mar '12 0:25    Post subject: Reply with quote

It looks like the Windows mod_jk 1.2.35 binaries for httpd-2.4 were compiled with a pre-release version of httpd. I posted a note in the tomcat-users list, so maybe they will get around to fixing this.

You can pretty easily compile it yourself to work with the 2.4.1 binary from Apache Lounge. You will need these tools installed to compile mod_jk on Windows32:To compile mod_jk, download the source code, unzip it, open a "Windows SDK 7.1 Command Prompt" from the Start menu, change to the directory where you unzipped the source code, ensure your web server is stopped, and do this:
Code:
CD tomcat-connectors-1.2.35-src\native\apache-2.0
NMAKE -f Makefile.vc APACHE24_HOME=\Apache24
COPY /Y Release24\mod_jk.so    \Apache24\modules\
COPY /Y Release24\mod_jk.pdb   \Apache24\modules\

I didn't test the module thoroughly, but I confirmed that this corrects the "is not compatible with this version of Apache" error at startup.

-tom


Last edited by tdonovan on Mon 26 Mar '12 12:40; edited 1 time in total
Back to top
mwu



Joined: 25 Mar 2012
Posts: 11

PostPosted: Mon 26 Mar '12 12:01    Post subject: Reply with quote

Thank you for the information.

I will try to build mod_jk with your instructions.

-----------

The new apache.org mod_jk binary from today is working with the 32bit apachelounge apache 2.4.1.

So, I don't need to build mod_jk.

@tdonovan:
Thank you for the support!

rg
Michael
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1