logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Forum Register Log in  RSS Apache Lounge


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.




PHP 5.3.10 has been released

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 4761
Location: Germany, Next to Hamburg

PostPosted: Fri 03 Feb '12 10:18    Post subject: PHP 5.3.10 has been released Reply with quote

In PHP 5.3.9 there is a serious security bug. Please update your installations to 5.3.10. Alternative: Disable your php Wink
Back to top
Kanashii



Joined: 17 Jul 2006
Posts: 152
Location: Porando

PostPosted: Fri 03 Feb '12 19:30    Post subject: Reply with quote

Problem:

http://thexploit.com/sec/critical-php-remote-vulnerability-introduced-in-fix-for-php-hashtable-collision-dos/

offtopic

How to make hot replace for new PHP

Use "unlocker" software to unlock folder where is PHP
Rename to phptmp
create folder php copy old files
replace with new php
I use Wincache so page are still available Smile

bat file hot.bat
TASKKILL /F /IM php-cgi.exe
httpd -n Apache -k restart

So will be gracefull restart old connection will be continue and new will be create new apache instance
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 4761
Location: Germany, Next to Hamburg

PostPosted: Sat 04 Feb '12 12:31    Post subject: Reply with quote

That hot thing works only when running php over fcgid.

Module or fcgid I create a new folder like php5310 change the paths in httpd.conf. Copy the php.ini change there the paths for the extensions and restart apache. Advantage I can switch back. Disadvantage it takes a bit longer
Back to top
KurtDJ



Joined: 27 Feb 2012
Posts: 2
Location: Virginia Beach

PostPosted: Mon 27 Feb '12 21:01    Post subject: Reply with quote

With this new release of php 5.3.10, i'm running Windows Server 2003 and Apache Server 2.2.22. i want to upgrade php to 5.3.10 but windows.php.net downloads site says not to use VC9 version with Apache binaries. am i able to upgrade?
Back to top
bagu



Joined: 06 Jan 2011
Posts: 79
Location: France

PostPosted: Mon 27 Feb '12 22:10    Post subject: Reply with quote

Quote:
Do NOT use VC9 version with apache.org binaries

VC9 versions of Apache can be fetched at Apache Lounge. We use their binaries to build the Apache SAPIs


So if you use apache from here, you can use php5.3.10 from php.net
Back to top
Rocker



Joined: 26 Feb 2012
Posts: 16
Location: Brazil

PostPosted: Tue 28 Feb '12 18:32    Post subject: Reply with quote

Hey, I'm using PHP VC9 (from php.net) with Apache from apache.org ...

It works fine.
Back to top
osportflio



Joined: 27 May 2011
Posts: 1

PostPosted: Thu 05 Apr '12 11:57    Post subject: Reply with quote

It's been days since 5.3.10 was released and still no word from cPanel! When you say you're working on it, what's to work on? Surely it's the same as 5.3.9 (which you've already released) but just includes 1 security fix. A day or two maybe, but several days???
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1