logoon  windows
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



Apache 2.2 and PHP 5.1.4 Installed and working BUT.........

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
pedro2k



Joined: 17 Jun 2006
Posts: 16

PostPosted: Sat 17 Jun '06 21:10    Post subject: Apache 2.2 and PHP 5.1.4 Installed and working BUT......... Reply with quote

Firstly may i say that this site was a god send and has save me from doing very damaging things to my PC'S!!!!!

Right i have php and apache working! (at last! - Thank you apache lounge!)
Well the service starts!

But i have put in the sample hello.php code from the www.php.net website and its not working.

But i dont know how to get it working!

Any advice please>

pedro
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2160
Location: Hilversum, NL, EU

PostPosted: Sat 17 Jun '06 22:49    Post subject: Reply with quote

Is php info working ?

Steffen
Back to top
pedro2k



Joined: 17 Jun 2006
Posts: 16

PostPosted: Sat 17 Jun '06 22:58    Post subject: Reply with quote

I'm ever so sorry but i dont know where or what that is!
Can you give me a little more detail please???

Sorry to be a pain!

Pedro
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 5078
Location: Germany, Next to Hamburg

PostPosted: Sun 18 Jun '06 15:20    Post subject: Reply with quote

phpinfo is a simple testfile

Code:

<?php
phpinfo();
?>


http://www.php.net/phpinfo

Any thing in the error log from apache or php error log?
Back to top
pedro2k



Joined: 17 Jun 2006
Posts: 16

PostPosted: Mon 19 Jun '06 21:42    Post subject: Reply with quote

This is the apache error log file,
This cant be good!
And i cant find the php error file where is it?

Any suggestions?

Pedro


apache - error.log

[Mon Jun 19 20:37:14 2006] [error] [client 192.168.1.1] File does not exist: C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/favicon.ico
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 5078
Location: Germany, Next to Hamburg

PostPosted: Tue 20 Jun '06 17:36    Post subject: Reply with quote

the php error log can be set in PHP.ini

how does your httpd.conf look? You did you bind PHP in?
Back to top
pedro2k



Joined: 17 Jun 2006
Posts: 16

PostPosted: Wed 21 Jun '06 19:28    Post subject: Reply with quote

Ok solved it and i feel a bit stupid now!
I had missed the line:-
AddType application/x-httpd-php .php
from my conf file!

The config web page i wsa following didn't mention it.
But i searched and found that i had to add this line!

So it all working now!

I just need to learn php npw!!!!

THANKS

Pedro
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1