logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Mod Perl

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
pnllan



Joined: 05 Dec 2005
Posts: 221

PostPosted: Mon 12 Dec '05 10:01    Post subject: Mod Perl Reply with quote

I cannot get ModPerl 2.0.2 to work the Apache 22 build.

I keep recieving the following start error:

Quote:
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 118 of D:/Apache22/conf/httpd.conf: Cannot load D:/Apache22/modules/mod_perl.so into server: The specified module could not be found. .


The file mod_perl.so is in the directory in question.

I had Mod Perl working in Apache 2.0.55.

Any ideas?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Mon 12 Dec '05 12:55    Post subject: Reply with quote

All modules need to be recompiled for 2.2.
This because the ModuleMagicNumber has changed.

I build mod_perl against 2.2 anad it is working fine.

I am not that perl guy, so I am still figuring out how I can distribute it as ppd.


Steffen
Back to top
Lutz-R. Frank



Joined: 03 Dec 2005
Posts: 21
Location: Germany

PostPosted: Tue 13 Dec '05 11:00    Post subject: Reply with quote

I confirm proper building of mod_perl.so (even on my Setup Smile) without errors.

Code:
Server Version: Apache/2.2.0 (Win32) DAV/2 PHP/5.1.1 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_perl/2.0.2 Perl/v5.8.7
Server Built: Dec 10 2005 09:07:53


The module loads and seems to be recognized, only the test script called by httpd.conf crashes my server, ie. adding the lines

Code:
# Edit file httpd.conf

PerlModule Apache2::Hello
<Location /hello>
   SetHandler modperl
   PerlResponseHandler Apache2::Hello
</Location>

# Create file C:\www\perl\site\lib\Apache2\Hello.pm

package Apache2::Hello;
use strict;
use Apache2::RequestRec (); # for $r->content_type
use Apache2::RequestIO (); # for $r->puts
use Apache2::Const -compile => ':common';
sub handler {
  my $r = shift;
  my $time = scalar localtime();
  my $package = __PACKAGE__;
  $r->content_type('text/html');
  $r->puts(<<"END");
  <HTML><BODY>
  <H3>Hello</H3>
  Hello from <B>$package</B>! The time is $time.
  </BODY></HTML>
  END
  return Apache2::Const::OK;
}
1;



doesn't start my server - without the <Location> Directive, its fine

Lutz
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Wed 14 Dec '05 22:59    Post subject: Reply with quote

It is only working here when I build with the latest snapshot mod_perl/2.0.3-dev at http://svn.apache.org/snapshots/modperl-2.0/


Steffen
Back to top
cody_rocco



Joined: 19 Dec 2005
Posts: 1

PostPosted: Sun 25 Dec '05 13:16    Post subject: Reply with quote

Steffen wrote:
All modules need to be recompiled for 2.2.
This because the ModuleMagicNumber has changed.

I build mod_perl against 2.2 anad it is working fine.

I am not that perl guy, so I am still figuring out how I can distribute it as ppd.


Steffen


maybe i can help in this problem, please contact me if you need
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1