logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.




One Time Password Mod

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
nweightman



Joined: 19 Jun 2012
Posts: 1
Location: England, London

PostPosted: Tue 19 Jun '12 21:59    Post subject: One Time Password Mod Reply with quote

Hey guys,
I've been searching everywhere for a OTP module for Apache. Their do seem to be a few out their, but this one mod_authn_otp does seem to look pretty good. Its used for One time password Authentication which you could use via a token or otp key generator for your mobile (which is what i want to try out)

Problem is, I don't know how to create module files nor have the nohow to generate the module for this software. I don't know if its linux only generated or can be ported to Windows.

http://code.google.com/p/mod-authn-otp/

Nicholas.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2155
Location: Sun Diego, USA

PostPosted: Wed 20 Jun '12 21:52    Post subject: Reply with quote

As most things are on google code, they are pretty much Unix only. This one looks like a challenge to port to Windows
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2155
Location: Sun Diego, USA

PostPosted: Thu 21 Jun '12 6:55    Post subject: Reply with quote

I might have this, I'm not sure. The 32 bit VC9 module loads in Apache 2.2.22 and the otptool.exe at least gives me the help screen. I do not have the time or inclination however to learn how to use it or test it.

There's differences in the auth stuff between Apache 2.2 & 2.4 and this is only for 2.2.x till the authors make it compatible with 2.4

This module & tool requires OpenSSL, that may become a pain when newer versions come out as it may need to be recomiled & linked to the newer version. The one I have built uses OpenSSL 1.0.1c.

I had to scrounge around for quite a bit of POSIX stuff, so things may or may not work. If they do great but if not I doubt I'd be able to get it to work under Windows.

Care to be the lab rat?
Back to top
karhukuoma



Joined: 31 Jan 2015
Posts: 8
Location: Finland

PostPosted: Sun 01 Feb '15 13:44    Post subject: Reply with quote

Any updates on this? Seems like the mod-authn-otp has been updated since these posts. At least the configuration guide is for Apache 2.x

I'm willing to do some testing with a build mod if needed. Using Apache 2.4.12 32bit VC11 build.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2155
Location: Sun Diego, USA

PostPosted: Sun 01 Feb '15 22:15    Post subject: Reply with quote

Edit: Old link removed, see new link below.

otptool.exe must be located in your Apache's bin folder to run (cause that is where the openssl libraries are)


Last edited by glsmith on Fri 04 Nov '16 19:12; edited 1 time in total
Back to top
karhukuoma



Joined: 31 Jan 2015
Posts: 8
Location: Finland

PostPosted: Tue 03 Feb '15 21:47    Post subject: Reply with quote

Thanks glsmith. Seems to be working. I used mod-authn-otp suggested service for Google Authenticator to generate secret.
Here is my config:
httpd.conf
Code:

LoadModule authn_otp_module modules/mod_authn_otp.so

httpd-ssl.conf
Code:

<Directory "C:/www/mysecret">
    AuthType basic
    AuthBasicProvider OTP
   OTPAuthLogoutOnIPChange On
   OTPAuthMaxLinger 14400
   OTPAuthMaxOTPFailure 20
   OTPAuthUsersFile "C:/software/Apache24/auth/otp_users.txt"
   AuthUserFile "C:/software/Apache24/auth/otp_pins.txt"
   OTPAuthPINAuthProvider file
   AuthName "MyStash"
   AllowOverride AuthConfig
   <RequireAll>
   Require valid-user
   Require env AllowCountry
   </RequireAll>
</Directory>

where AllowCountry is GeoIP stuff.
Used htpasswd file for external pin verification as documentation suggests.
Back to top
karhukuoma



Joined: 31 Jan 2015
Posts: 8
Location: Finland

PostPosted: Sun 13 Dec '15 0:03    Post subject: Request for VC14 build Reply with quote

Could you build VC14 binary from the latest sources
https://github.com/archiecobbs/mod-authn-otp
I'm going to use httpd-2.4.18-win32-VC14.zip Apache binaries.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2155
Location: Sun Diego, USA

PostPosted: Sun 13 Dec '15 8:28    Post subject: Reply with quote

https://www.apachehaus.net/modules/mod_authn_otp/
calling it version 1.1.7.1 (1.1.7 + commit 192fd2e)
both x86 & x64 VC14 builds in package.


Last edited by glsmith on Fri 04 Nov '16 19:12; edited 1 time in total
Back to top
karhukuoma



Joined: 31 Jan 2015
Posts: 8
Location: Finland

PostPosted: Sun 13 Dec '15 16:44    Post subject: Reply with quote

Thanks.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1