logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



mod_proxy_http.so run on apache-2.2-win 32 on win-2008-R2-64

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 17:51    Post subject: mod_proxy_http.so run on apache-2.2-win 32 on win-2008-R2-64 Reply with quote

I am trying to install mod_proxy_http.so and libxml2.dll on apache 2.2 (32 bit) running on windows 2008 R2 64 bit server.

It got the precompiled modules from http://www.apachelounge.com/. When I use the 64 bits, apache told me to use 32 bits (since the apache is 32 bit). When I use the 32 bits, apache fail to load the module.

Can anyone of you have precompiled modules that would work for apache 2.2 win32 on windows 2008 R2 64 bit server?

Thanks
Eric
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 08 Aug '13 18:24    Post subject: Reply with quote

What error do you get in the Windows Event viewer and/or Apache error log ?
Back to top
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 19:02    Post subject: mod_proxy_http.so run on apache-2.2-win 32 on win-2008-R2-64 Reply with quote

When I Use 32 modules

The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 360 of D:/ASAS/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load D:/ASAS/Apache Software Foundation/Apache2.2/modules/mod_proxy_html.so into server: The specified module could not be found.

When I Use 64 modules
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 360 of D:/ASAS/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load D:/ASAS/Apache Software Foundation/Apache2.2/modules/mod_proxy_html.so into server: The Apache service named is not a valid Win32 application.


Thanks
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 08 Aug '13 19:12    Post subject: Reply with quote

Why you try to use a Win64 with a Win32 Apache ?

What 2.2 version of Apache you running ?

Where did you download your Apache 2.2.x ?

Did you follow exactly the instruction in the Readme of mod_proxy_html-3.1.4-win32.zip ? Special attention that you have to load two modules mod_proxy_html.so and mod_xml2enc.so:

Be sure you have installed the Visual C++ 2010 SP1 Redistributable Package x64,
download and install, if you not have it already, from:

http://www.microsoft.com/download/en/details.aspx?id=13523


# Install:

Copy mod_proxy_html.so, mod_xml2enc.so to the apache Modules folder
Copy libxml2.dll to the apache Bin folder


# Add to your httpd.conf

LoadModule proxy_html_module modules/mod_proxy_html.so
LoadModule xml2enc_module modules/mod_xml2enc.so
Back to top
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 19:48    Post subject: Reply with quote

Why you try to use a Win64 with a Win32 Apache ?

I am not the one who decide. But it is a win32 apache in the existing win64 environment. One of the reason may be that apache has to integrate with other software that only support 32 bit version on this window platform

What 2.2 version of Apache you running ?
Apache/2.2.22 (Win32)

Where did you download your Apache 2.2.x ?
httpd-2.2.22-win32-x86-openssl-0.9.8t
http://www.apache.org/


Did you follow exactly the instruction in the Readme of mod_proxy_html-3.1.4-win32.zip ? Special attention that you have to load two modules mod_proxy_html.so and mod_xml2enc.so.

I put
Copy mod_proxy_html.so, mod_xml2enc.so to the apache Modules folder
Copy libxml2.dll to the apache Bin folder

Add to httpd.conf

LoadModule proxy_html_module modules/mod_proxy_html.so
LoadModule xml2enc_module modules/mod_xml2enc.so

Include proxy_html.conf

Still cannot find the module when restart

***************

I guess it may need some cross-compiling but I am not 100% sure Smile
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 08 Aug '13 20:22    Post subject: Reply with quote

Did you as written in the Readme:

Be sure you have installed the Visual C++ 2010 SP1 Redistributable Package x86,
download and install, if you not have it already, from:

http://www.microsoft.com/download/en/details.aspx?id=8328


When it not works, try Apache 2.2 from here, it is not advised to use the one from apache.org which is build with VC6 instead of VC10.
Back to top
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 20:36    Post subject: mod_proxy_http.so run on apache-2.2-win 32 on win-2008-R2-64 Reply with quote

Hi

I would also need
mod_proxy_http.so
run on apache-2.2-win 32 on win-2008-R2-64

Can you point out where I can acquire those?

Thanks and regards,
Eric
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2600
Location: Hilversum, NL, EU

PostPosted: Thu 08 Aug '13 20:41    Post subject: Reply with quote

That is a standard Apache module.
Un-comment in your httpd.conf:

#LoadModule proxy_http_module modules/mod_proxy_http.so
Back to top
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 20:44    Post subject: Reply with quote

Hello

after installing the MSVC stuff, it works!!
Thanks a lot

Eric
Back to top
erictse2



Joined: 08 Aug 2013
Posts: 9
Location: Canada, Toronto

PostPosted: Thu 08 Aug '13 20:45    Post subject: mod_proxy_http.so run on apache-2.2-win 32 on win-2008-R2-64 Reply with quote

Thanks I will uncomment this.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1