logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.




mod_security2 error with xampp

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
Menaka



Joined: 18 Jun 2013
Posts: 19
Location: India

PostPosted: Wed 24 Jul '13 16:13    Post subject: Reply with quote

Can someone help on this error.
httpd: Syntax error on line 146 of C:/xampp/apache/conf/httpd.conf: Cannot load
modules/mod_security2.so into server: The specified procedure could not be found

Got this error when i tried running Apache.
I have downloaded mod_security.so(2.7.4) from ApacheLounge/downloads and placed inside apache/modules/ folder.
Added, following lines in httpd.conf,

LoadModule unique_id_module modules/mod_unique_id.so
146 th line contains:
LoadModule security2_module modules/mod_security2.so

OS: Windows 7 32 bit
XAMPP v1.8.1
Apache 2.4.3
Installed vc++ package from http://www.microsoft.com/en-us/download/details.aspx?id=8328
mod_security-2.7.4
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 555

PostPosted: Wed 24 Jul '13 16:37    Post subject: Reply with quote

Although xampp uses the binaries from here, they screwed some up.

Please read about replacing ddl's : www.apachelounge.com/viewtopic.php?t=5397
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6340
Location: Germany, Next to Hamburg

PostPosted: Thu 25 Jul '13 9:54    Post subject: Reply with quote

admin wrote:
Although xampp uses the binaries from here, they screwed some up.


Did you contact the xampp people so the problem get fixed soon?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2638
Location: Hilversum, NL, EU

PostPosted: Thu 25 Jul '13 10:18    Post subject: Reply with quote

Yep by mail and see www.apachelounge.com/viewtopic.php?t=5434

Had also contact with BitNami, who are helping package the XAMPP stacks

Steffen
Back to top
Menaka



Joined: 18 Jun 2013
Posts: 19
Location: India

PostPosted: Thu 25 Jul '13 15:07    Post subject: Reply with quote

Hi All, the issue got resolved when i replaced the 2 dll(libxml2 and pcre) files in bin directory with the file available in http v2.4.6 binary file.

Thanks a lot Steffen & admin for the input.

Referred topic:
www.apachelounge.com/viewtopic.php?t=5397
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1