logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Weird Windows 8 / Port 80 problem

 
Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking



View previous topic :: View next topic  
Author Message
jvet56



Joined: 01 Jan 2014
Posts: 4
Location: SF Bay Area, CA

PostPosted: Wed 01 Jan '14 22:27    Post subject: Weird Windows 8 / Port 80 problem Reply with quote

Fairly new to running a home server, so please consider offering step-by-step kind of responses.

- I installed apache 2.4.7. on Windows 8.1.
- I set port forwarding on router to port 80, and assigned it to the internal IP (192.168.x.x).
- I edited the host file to map IP to hostname (127.0.0.1 website.dyndns.com)
(I'm using dyndns service to point web requests to my hostname)
- I can ping my "website.dyndns.com" address, my external IP, and my internal IP of the server and get a proper response (Reply from xx.xx.xx.xx: bytes=32 time=1ms TTL=64)
- netstat -oan shows the only application using port 80 is apache
- But I can't connect on port 80 on the server from any other computers.
- I try to connect to my server from the web using the website.dyndns.com address, OR the external IP (74.xx.xx.xx) and it won't access the web pages - I get a "timed out" error or a "connection was reset" error.
- However, if I change settings to listen on port 8080 I CAN connect to website.dyndns.com:8080
- My ISP is NOT blocking port 80.
** I want to be able to access my web site by its web address (website.dyndns.com) without having to append :8080
I've spent hours trying to find info on the web that will tell me how to get my server to accept requests on port 80, but can't find a solution.

Previously, I had a server set up on a Windows XP machine, and everything worked beautifully. But on Windows 8, apparently port 80 isn't available, and I can't tell which app/service is locking port 80.

Lastly, when I check my apache logs, I see that requests were received, (returns code 202 - successful connection). google web tools can access the site. Yet none of my 3 other computers (windosw 7, OSX, Ubuntu) can reach my site.

Pulling (what's left of) my hair out over this!

-- John
Back to top
jraute



Joined: 13 Sep 2013
Posts: 187
Location: Rheinland, Germany

PostPosted: Thu 02 Jan '14 1:11    Post subject: Reply with quote

Have you checked your windows firewall for port 80?
And what are doing the google tools there?
Back to top
jvet56



Joined: 01 Jan 2014
Posts: 4
Location: SF Bay Area, CA

PostPosted: Thu 02 Jan '14 2:42    Post subject: Reply with quote

Windows firewall is set to allow apache through port 80.

I had the server running before on an XP machine, and used google tools for stats and to index the site.

jraute wrote:
Have you checked your windows firewall for port 80?
And what are doing the google tools there?
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2121
Location: Sun Diego, USA

PostPosted: Thu 02 Jan '14 6:37    Post subject: Reply with quote

Quote:
- I edited the host file to map IP to hostname (127.0.0.1 website.dyndns.com)


I think you should undo this even though it is probably not the problem. If you want to do this, use some other domain name like www.mysite.com instead of a real dundns domain name. You can just add a ServerAlias www.mysite.com to your config for it.

If google can see it, and you can get to it from a remote location, I'm thinking that your router is not supporting loopback. Some routers don't and I know between LinkSys and DLink, they each do it differently.
Back to top
jraute



Joined: 13 Sep 2013
Posts: 187
Location: Rheinland, Germany

PostPosted: Thu 02 Jan '14 12:19    Post subject: Reply with quote

Strange thing that google comes through and the connect from outside and inside is not working except you use port 8080.

Since firewall is not the problem i would look for the httpd file. Can you configure it like you did with port 8080 but instead of 8080 just with 80? I mean change all settings with 8080 to 80 and test again.
And check your router if it has a proxy running on 8080 ...

Greets and a happy new year!
Back to top
clariceoshea



Joined: 17 Feb 2014
Posts: 6
Location: Houston,Texas

PostPosted: Wed 19 Feb '14 5:55    Post subject: Reply with quote

had this problem and the ISP was blocking 80 in Apache so I used 8080

and made the change to httpd.conf in /etc/httpd/conf
Listen 8080
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Hardware & Networking
Page 1 of 1