logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



PHP 7.1.11, 7.0.25, 5.6.32, 5.5.38, 5.4.45, 5.3.29 available
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Wed 28 Sep '16 18:13    Post subject: Reply with quote

Updated all to OpenSSL 1.0.2j with FIPS 2.0.13
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Thu 03 Nov '16 9:37    Post subject: Reply with quote

Updated all builds to CUrl 7.51.0
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Sat 03 Dec '16 16:42    Post subject: Reply with quote

I have a problem with the php_memcache.dll extension for PHP 7.1. Using it for normal gets and sets works fine, but we also use php_memcache.dll as our session handler and for some reason, either the version of the extension built here or something has change so we get this error:

session_start(): Failed to read session data: user (path: tcp://localhost:11211)

Here is how we are loading it:

session_set_save_handler(new \PRIDE\MemcachedSession());
session_start();

I can post the class code if that helps, but this works fine when I rollback to 7.0.13 and the previous version of the php_memcache.dll extension
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Sat 03 Dec '16 22:44    Post subject: Reply with quote

I am using the same code for building the extension for PHP 7.0 and 7.1: https://github.com/websupport-sk/pecl-memcache

The have been a few recent changes in the code. Which version of PHP 7.0.13 are you using? x86, x64, TS or NTS? I will recompile that version with the latest memcache sources, so we can determine if it is change in the memcache sources ot a change between PHP 7.0 and PHP 7.1 that causes the difference.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Sat 03 Dec '16 22:49    Post subject: Reply with quote

7.0.13 x86 VC14 NTS
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Sat 03 Dec '16 23:06    Post subject: Reply with quote

I had made a guess that you were using the X64 NTS version. I am bad gambler, so I stopped that build. It will take some time bacause I am always building the whole lot in one go.

In the mean time: could you find out the build date of the working PHP 7.0.13 extension? Most likely ot is in November, so only a test has changed in the sources:
https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Sat 03 Dec '16 23:28    Post subject: Reply with quote

https://phpdev.toolsforresearch.com/php_memcache-7.0.13-x86-nts.zip

Complete build follows later, but what are the effects if you replace the php_memache.dll in your working solution with the one in this zip?
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Sun 04 Dec '16 0:04    Post subject: Reply with quote

Jan-E wrote:

In the mean time: could you find out the build date of the working PHP 7.0.13 extension? Most likely ot is in November, so only a test has changed in the sources:
https://github.com/websupport-sk/pecl-memcache/commits/NON_BLOCKING_IO_php7


How do I find that? It was this one that you built:

Quote:
Edit 2016-01-07: PHP 7.0.2, 5.6.17, 5.5.31
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Sun 04 Dec '16 0:06    Post subject: Reply with quote

Jan-E wrote:
https://phpdev.toolsforresearch.com/php_memcache-7.0.13-x86-nts.zip

Complete build follows later, but what are the effects if you replace the php_memache.dll in your working solution with the one in this zip?


If you saw that response, ignore it, I thought that was for 7.1, testing it now with 7.0.13.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Sun 04 Dec '16 0:09    Post subject: Reply with quote

That build works fine with 7.0.13.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Thu 08 Dec '16 16:19    Post subject: Reply with quote

Keith (aka laurin1),

The memcache devs will look into PHP7.1 compatibility. See https://github.com/websupport-sk/pecl-memcache/issues/11#issuecomment-265740146
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Thu 08 Dec '16 17:27    Post subject: Reply with quote

Thanks for all your hard work Jan.
Back to top
rsdev000



Joined: 17 Dec 2016
Posts: 1
Location: lisbon

PostPosted: Sun 18 Dec '16 13:34    Post subject: Reply with quote

** SOLVED: Downloaded the x64 version and it's ok.

Hi.

I'm having problems with some extensions:
PHP Warning: PHP Startup: Unable to load dynamic library - 'C:\work\servers\web\php70nts\ext\php_curl.dll' Attempt to access invalid address. in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\work\servers\web\php70nts\ext\php_readline.dll' - The specified module could not be found.

These are not the only ones. I don't have the problems with php.net's PHP 7.0.14 and PHP 7.1.0 installed in the same folder so I think it's not a path issue.

I'm on a Windows 10 Pro x64 with latest nginx from nginx.org and php nts x86 7.x.

What could be the issue?

Thanks in advance
Back to top
nono303



Joined: 20 Dec 2016
Posts: 3
Location: France, Lille

PostPosted: Wed 21 Dec '16 14:08    Post subject: php_memcache Reply with quote

Hi,
For php_memcache module, you could get binaries at https://github.com/nono303/PHP7-memcache-dll
for 7.0.x & 7.1.x, x64 & x86, TS & NTS, VC14 & VC15
Arnaud
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Fri 23 Dec '16 20:28    Post subject: Reply with quote

I updated all these builds to CURL 7.52.1.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Thu 12 Jan '17 19:59    Post subject: Reply with quote

laurin1 wrote:
I have a problem with the php_memcache.dll extension for PHP 7.1. Using it for normal gets and sets works fine, but we also use php_memcache.dll as our session handler and for some reason, either the version of the extension built here or something has change so we get this error:

session_start(): Failed to read session data: user (path: tcp://localhost:11211)

Here is how we are loading it:

session_set_save_handler(new \PRIDE\MemcachedSession());
session_start();

I can post the class code if that helps, but this works fine when I rollback to 7.0.13 and the previous version of the php_memcache.dll extension


Ok, so I just tested this on a different machine (configured identically, AFAIK) and it works. What could be different between the 2 machines where one would work and one wouldn't? I checked memcached versions, but I am using the same on both.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Thu 12 Jan '17 22:06    Post subject: Reply with quote

@Keith aka Laurin1: I really would not know. Nothing in the sources have changed since september 2016.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Thu 12 Jan '17 22:58    Post subject: Reply with quote

I understand, but it seems to me that that just means something has changed with the session handler or associated code in PHP that is the problem.
Back to top
laurin1



Joined: 26 Oct 2014
Posts: 19
Location: Flower Mound, TX

PostPosted: Mon 16 Jan '17 22:54    Post subject: Reply with quote

Well, I fixed it by just changing out my Memcache session class with the one here: https://github.com/nono303/PHP7-memcache-dll

I still don't know exactly what was wrong or what changed that was causing the problem, but that seems to work.

Weird.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 785
Location: Amsterdam, NL, EU

PostPosted: Tue 24 Jan '17 17:00    Post subject: Reply with quote

Updated all builds (24 in total) to OpenSSL FIPS 2.0.14 (combined with OpenSSL 1.0.2j). next update will follow after the release of OpenSSL 1.0.2k on Thursday 26th.
https://www.openssl.org/source/
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 5 of 7