logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



LDAP apache Active Directory SSL connection

 
Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips



View previous topic :: View next topic  
Author Message
sintro



Joined: 09 Feb 2015
Posts: 1
Location: Australia

PostPosted: Mon 09 Feb '15 9:00    Post subject: LDAP apache Active Directory SSL connection Reply with quote

Just want to provide a solution to a problem I had recently when trying to configure Apache 2.4.9 to connect to Active Directory using SSL. (WAMP version 2.5)

I was getting the error:
"[Mon Feb 09 14:31:25.552692 2015] [authnz_ldap:info] [pid 3104:tid 1020] [client 10.0.0.1:49987] AH01695: auth_ldap authenticate: user peter authentication failed; URI /favicon.ico [LDAP: ldap_simple_bind() failed][Unavailable]"

This error occured because my AuthLDAPURL was:

AuthLDAPURL ldaps://10.0.0.5:636/DC=site1,DC=mydomain,DC=com?sAMAccountName?sub?(objectClass=user)

Connecting to Active Directory over SSL does not work with IP address and it must be the full hostname.

AuthLDAPURL ldaps://dc1.site1.mydomain.com:636/DC=site1,DC=mydomain,DC=com?sAMAccountName?sub?(objectClass=user)

What confused me was that setting AuthLDAPURL with the IP address in the URL worked when not using SSL.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips
Page 1 of 1