logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Tomcat Connectors (mod_jk) 1.2.41 (issue)

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Tue 25 Aug '15 10:45    Post subject: Tomcat Connectors (mod_jk) 1.2.41 (issue) Reply with quote

Hello Apache Lounge Team,

On apache.org is a new version of Tomcat Connector (mod_jk) online.

Apache Tomcat Connectors 1.2.41

Changelog: http://tomcat.apache.org/connectors-doc/miscellaneous/changelog.html

Can you please build a VC11 x86/x64 ?

Thank You!!!

TPL
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Tue 25 Aug '15 12:35    Post subject: Reply with quote

Done.

Please verify if all is ok, then I build it for VC14/10
Back to top
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Wed 26 Aug '15 8:17    Post subject: Reply with quote

Thank You, Steffen!

Tested on Windows Server 2008 R2 SP1 with Apache 2.4.16 VC11 x86:

There's a bug in mod_jk version 1.2.41 on Windows with the status worker.

Example:

Code:
worker.list=jk-status
worker.jk-status.type=status
worker.jk-status.read_only=true


Code:
<Location /jk-status>
        JkMount jk-status
        Require local
</Location>


http://localhost/jk-status returns no result.

Rainer Jung confirmed the problem.
He sends me a Workaround to fix it and works on a permanent solution.

Workaround:
Edit mod_jk.so (i use notepad++)
Just replace the "%z" (two times) in the mod_jk.so with blank spaces.


Regards
Timo
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Wed 26 Aug '15 9:26    Post subject: Reply with quote

TPL wrote:


Workaround:
Edit mod_jk.so (i use notepad++)
Just replace the "%z" (two times) in the mod_jk.so with blank spaces.


Hi Timo,

you edited the so file ( dll) with NP++ and it still works?
Back to top
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Wed 26 Aug '15 9:43    Post subject: Reply with quote

Yes. It's magic! Very Happy

The problem is a Timezone parameter. Edit and safe the .so file and it works.

Code:
Y-%m-%d %H:%M:%S %z    %Y%m%d%H%M%S    %z


But, not only delete %z. Overwrite with blank spaces.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Wed 26 Aug '15 11:32    Post subject: Reply with quote

Please keep me informed.

You can download the "old" 1.2.40 :

On request
Back to top
rjung



Joined: 26 Aug 2015
Posts: 2

PostPosted: Wed 26 Aug '15 21:30    Post subject: Reply with quote

I added the issue information the the following bugzilla ticket including the workarounds:

https://bz.apache.org/bugzilla/show_bug.cgi?id=58286

I will update the ticket when we have a final fix.

Since jk-status is an important feature and a crash is not something to tolerate I suggest you consider applying one of the workarounds to your binary builds.

Thanks and sorry for the inconvenience.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Wed 26 Aug '15 22:15    Post subject: Reply with quote

Thanks rjung.

Applied temporarily fix jk-status timezone and did a rebuild. Available at the VC11 download page.

Please test again (TPL ?).
Back to top
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Thu 27 Aug '15 8:27    Post subject: Reply with quote

Tested on Windows Server 2008 R2 SP1 with Apache 2.4.16 VC11 x86

The status worker page is available now.
It seems to work!


Thanks!

Regards
Timo
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Sat 29 Aug '15 10:57    Post subject: Reply with quote

Applied final fix jk-status timezone, see https://svn.apache.org/viewvc?view=revision&revision=1698316 (thanks rjung).

Available at the VC11 download page.

Please test, when all fine then I build it for VC14/10.
Back to top
TPL



Joined: 25 Mar 2014
Posts: 23
Location: Germany, Hamburg

PostPosted: Mon 31 Aug '15 9:04    Post subject: Reply with quote

Tested on Windows Server 2008 R2 SP1 with Apache 2.4.16 VC11 x86:

everything works fine!

Info:
LogLevel = debug
On startup there are the following messages in apache error.log.

[Mon Aug 31 08:33:27.633842 2015] [jk:error] [pid 3024] [Mon 31 Aug 2015 08:33:27][3024:3064] [debug] jk_shm_close::jk_shm.c (403): Closed shared memory memory childs=1
[Mon Aug 31 08:33:27.727442 2015] [mpm_winnt:notice] [pid 3024:tid 432] AH00455: Apache/2.4.16 (Win32) mod_jk/1.2.41 configured -- resuming normal operations
[Mon Aug 31 08:33:27.727442 2015] [mpm_winnt:notice] [pid 3024:tid 432] AH00456: Apache Lounge VC11 Server built: Jul 12 2015 10:56:48

and

[Mon Aug 31 08:33:27.727442 2015] [mpm_winnt:notice] [pid 3024:tid 432] AH00418: Parent: Created child process 6948
[Mon Aug 31 08:33:28.772644 2015] [jk:error] [pid 6948] [Mon 31 Aug 2015 08:33:28][6948:6496] [debug] jk_shm_close::jk_shm.c (403): Closed shared memory memory childs=1
[Mon Aug 31 08:33:28.866244 2015] [mpm_winnt:notice] [pid 6948:tid 372] AH00354: Child: Starting 200 worker threads.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1