logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Having difficulty installing mod_security on Apache in Windo

 
Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules



View previous topic :: View next topic  
Author Message
selecta



Joined: 02 Sep 2008
Posts: 16

PostPosted: Tue 02 Sep '08 12:27    Post subject: Having difficulty installing mod_security on Apache in Windo Reply with quote

I have trying to install and configure mod_security on Apache but anytime I uncomment
#LoadModule security2_module modules/mod_security2/mod_security2.so

I get this error message

httpd.exe: Syntax error on line 117 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/Apache Software Foundation/Apache2.2/modules/mod_security2/mod_security2.so into server: The specified module could not be found

I installed the Apache2.2 is working fine
What I want is if I can get step by step instructions on how I can install and configure mod_security 2 on Apache. I have been struggling for the past three weeks. Any help will be highly appreciated

Thank you

Wisdom
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Tue 02 Sep '08 13:51    Post subject: Reply with quote

You downloaded mod_security from apachelounge? Did you follow the readme.txt ? Did you enable unique_id ?
Back to top
selecta



Joined: 02 Sep 2008
Posts: 16

PostPosted: Tue 02 Sep '08 14:32    Post subject: Reply with quote

Yes mod unique_id is enabled
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Tue 02 Sep '08 16:31    Post subject: Reply with quote

Seeing this
C:/Program Files/Apache Software Foundation/Apache2.2/conf/
makes me believe that this is a package from the Apache Foundation.

I do not think the Apache Lounge binary works on Apache from ASF, only Apache Lounge packages.

I may be wrong, Steffen, James?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6255
Location: Germany, Next to Hamburg

PostPosted: Tue 02 Sep '08 17:44    Post subject: Reply with quote

I just download apache from ASF and installed it. No Problems loads fine.

Maybe selecta did not install Visual C++ 2008 Redistributable Package or did not copy libxml2.dll to apache\bin
Back to top
RoiDanton



Joined: 11 Apr 2017
Posts: 4

PostPosted: Tue 11 Apr '17 14:50    Post subject: Same here Reply with quote

Hi all,

and sorry for rising this again Smile

I just downloaded both bins from apache lounge and ran into the same problem.

The apache is already running as a reverse proxy and I tried to integrate the security mod now.
But it failed as described. I followed exactly the readme files. I can see the file in the folder but http -t keeps telling me "The specified module could not be found."

Any help will be highly appreciated

Thank you!

Roi
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 549

PostPosted: Tue 11 Apr '17 15:04    Post subject: Reply with quote

Sure all is win32 or win64 ?
Back to top
RoiDanton



Joined: 11 Apr 2017
Posts: 4

PostPosted: Tue 11 Apr '17 16:27    Post subject: Reply with quote

Yes I'm sure everything is x64.
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 549

PostPosted: Tue 11 Apr '17 16:47    Post subject: Reply with quote

Recheck if you copied all the files, see readme.


Btw.

What version of Apache and mod-security are you running.
Back to top
RoiDanton



Joined: 11 Apr 2017
Posts: 4

PostPosted: Wed 12 Apr '17 10:46    Post subject: Reply with quote

I have downloaded the following files:

11.04.2017 13:14 <DIR> httpd-2.4.25-win64-VC14
11.04.2017 13:14 15.189.553 httpd-2.4.25-win64-VC14.zip
11.04.2017 13:17 <DIR> mod_security-2.9.1-win64-VC14
11.04.2017 13:13 770.697 mod_security-2.9.1-win64-VC14.zip

The file locations:

"D:\Atlassian\Apache24\bin\yajl.dll"
"D:\Atlassian\Apache24\modules\mod_security2.so"

from the httpd.conf:

ServerRoot "D:/Atlassian/Apache24"
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule security2_module modules/mod_security2.so

As I mentionent before the apache was allready runing as reverse proxy.
So its not a problem with the apache.

But httpd tells me:

D:\Atlassian\Apache24\bin>httpd.exe -t
httpd.exe: Syntax error on line 180 of D:/Atlassian/Apache24/conf/httpd.conf: Cannot load modules/mod_security2.so into server: The specified module could not be found.

Thanks for your tries so far Smile
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 549

PostPosted: Wed 12 Apr '17 11:03    Post subject: Reply with quote

Did you copied libcurl.dll to your apache/bin folder ?
Back to top
RoiDanton



Joined: 11 Apr 2017
Posts: 4

PostPosted: Wed 12 Apr '17 11:22    Post subject: Reply with quote

wooops and here we go Smile

I have missed that... Sad
Thank you admin for your help!
Its now working Wink
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache third-party Modules
Page 1 of 1