logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache 2.0.59 OpenSSL compile problem (fixed) but why?

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
some_cs_student



Joined: 16 Aug 2006
Posts: 5

PostPosted: Thu 17 Aug '06 11:24    Post subject: Apache 2.0.59 OpenSSL compile problem (fixed) but why? Reply with quote

Hi guys,

This one is OpenSSL/Apache 2.0.59 specific (I think), I grabbed version 0.9.8b of OpenSSL and Apache, and zlib etc. as advised by the tutorial.

I followed this tutorial:
http://www.devside.net/web/server/windows/apache

And managed to eventually get everything working, what I'm curious about is why I had to patch this file the way I did, and will there be any bad side-effects of doing so.

Anyway, here's the error:
Code:
     cd modules\ssl
       NMAKE -nologo -f mod_ssl.mak         CFG="mod_ssl - Win32 Release" RECU
SE=0  .\Release\mod_ssl.so
Warning: cannot find "mod_ssl.dep"
       if not exist ".\Release/" mkdir ".\Release"
       tempfile.bat
(null): cannot open file `??F': No such file or directory
The system cannot find the file specified.
Could Not Find C:\build\try2\httpd-2.0.59\modules\ssl\y.tab.c
The system cannot find the file specified.
Could Not Find C:\build\try2\httpd-2.0.59\modules\ssl\y.tab.h
NMAKE : fatal error U1077: 'tempfile.bat' : return code '0x1'
Stop.
NMAKE : fatal error U1077: 'C:\PROGRA~1\MICROS~3\VC98\BIN\NMAKE.EXE' : return c
de '0x2'
Stop.
NMAKE : fatal error U1077: 'C:\PROGRA~1\MICROS~3\VC98\BIN\NMAKE.EXE' : return c
de '0x2'
Stop.


And I found this article in a fairly random fashion while searching for the solution:
http://svn.haxx.se/dev/archive-2002-11/att-1207/subversionbuild.txt

Code:
"
7.) Open mod_ssl.mak in c:\httpd-2.0\modules\ssl\mod_ssl.mak and make the following
        changes (Note: characters like this were added).
   
           SOURCE=.\ssl_expr_parse.c
           #"$(INTDIR)\ssl_expr_parse.obj" : $(SOURCE) "$(INTDIR)"
           SOURCE=.\ssl_expr.scan.c
          #"$(INTDIR)\ssl_expr_scan.obj" :$(SOURCE) "$(INDIR)"
"


I did exactly this and it worked great, however *why* did I need to do this?
I couldn't find it documented anywhere...

I know have my own custom compiled Apache server Smile

Also, is this the correct way to do things? The apache server appears to run with the SSL certificate enabled ok, are there any side effects of commenting out those files? (I haven't yet bothered to read the C-code there, I'll do that tommorow).

Regards,
Gareth
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1