logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache VC14 having trouble in 2012 R2 Server

 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Anitha



Joined: 25 Sep 2016
Posts: 4
Location: india

PostPosted: Thu 20 Oct '16 20:35    Post subject: Apache VC14 having trouble in 2012 R2 Server Reply with quote

Hi Team,

Have a Great day.

I have compiled the Apache 2.4.23 with VC 14. successfully compiled and i am able to install on 2012 servers with vc_redist.x64.exe update3 patch.

Issue 1:
compiled the Apache in win32 and do we need to install both vc_redist.x64.exe vc_redist.x86.exe to up and run the Apache process ?

Issue 2:
2012 R2 servers does not allow to install vc_redist.exe both 64 and 32 bit. getting setup failed error.
Beased on the error i have installed windows patch "Windows8.1-KB2999226-x64" and retried the vc update 3. Still facing the same setup error issue.

Error : 0x80240017: Failed to execute MSU package.

Team please help me to resolve the issue.

Thanks in Advance,
Anitha.S
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2101
Location: Sun Diego, USA

PostPosted: Thu 20 Oct '16 23:29    Post subject: Reply with quote

I had this happen. I was able to install the update redistributable only after I installed the original VC redistributable (not any update). I installed the first one and then I was able to install the update version that was available at the time.
https://www.microsoft.com/en-us/download/details.aspx?id=48145

You only need the 32 bit unless you are running something else that is x64. Your OS is x64 so you may as well do both anyway, they are not huge like a .Net framework.
Back to top
yosoyminero



Joined: 16 Jun 2015
Posts: 11
Location: Spain

PostPosted: Thu 20 Oct '16 23:35    Post subject: Reply with quote

Hi, the following instructions work for Windows 8.1, but I suspect it is exactly the same problem:

Due to a known limitation on the implementation of the Microsoft Visual C++ 2015 (v14.0) Redistributable Package Update 3, its installation on Windows® 8.1 requires that both the additional, optional April 2014 KB2919355 Cumulative Update and the May 2014 KB2975061 servicing stack update for Windows 8.1 and Windows Server 2012 R2 are previously installed on the system.

Since KB2919355 has its own set of prerequisites and dependencies, in the end all the following updates need to also be previously installed on Windows® 8.1 systems, in the following specific order:

KB2975061
ClearCompressionFlag
KB2919355 (including updates KB2932046, KB2959977, KB2937592, KB2938439 and KB2934018)
KB2999226
At this point, if all the previously mentioned Windows® updates have been successfully installed, Microsoft Visual C++ 2015 (v14.0) Redistributable Package Update 3 can also be successfully installed.

More details (and links) in the "How to manually install the required Microsoft Visual C++ Redistributable Packages?" section of the following webpage:

http://xtack.org/documentation.html

Hope this helps Smile
Back to top
Anitha



Joined: 25 Sep 2016
Posts: 4
Location: india

PostPosted: Fri 21 Oct '16 7:20    Post subject: Reply with quote

Hi glsmith /yosoyminero,

Thanks for reply. but i am facing issues.

smith :
full vc++14 installable is not possible with our project. And tried installing both x86 and x64 both failed with same error.

yosoyminero :
I have tried installing the patch one by one, KB2975061 and ClearCompressionFlag installed sucessfully. After tried to install the patch KB2919355 , KB2999226 and got the popup " its not applicable for your server.

Tried again vc_redistributable update 3 getting same error Sad.

My server is 2012 R2 unable install the compiled appache. Please help me to resolve the issue.

Thanks in Advance,
Anitha.S
Back to top
yosoyminero



Joined: 16 Jun 2015
Posts: 11
Location: Spain

PostPosted: Fri 21 Oct '16 19:25    Post subject: Reply with quote

Hi Anitha,

I believe that's because, if I remember well, there were specific versions of those KB packages for different Windows versions.

Try to make sure to find the appropriate version of the KBs for Windows Server 2012, as the ones for Windows 8.1 are most likely not valid.

Good luck!
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads
Page 1 of 1