logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored by anyone.

Your donations will help to keep this site alive and well, and continuing the building of the binaries.



php5apache2_4.dll for PHP 5.6?

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
sam452



Joined: 19 Dec 2016
Posts: 5
Location: US, Nashville

PostPosted: Mon 19 Dec '16 17:57    Post subject: php5apache2_4.dll for PHP 5.6? Reply with quote

Cannot load c:/php/php5apache2_4.dll into server:

I have a working Apache 2.2 install on a Windows Server 2008 r2 that is running php 5.3.8

Itís past time to upgrade it.

Downloaded and installed Apache24 from this site and it seems to run but will not serve any PHP pages as PHP.

This server suggests it is Win64.
Installed Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.61030

Downloaded the latest php2_4.dll from https://www.apachelounge.com/download/additional/ which the latest seems to be for PHP 5.4.

This server has PHP 5.6.29 installed and the Windows CMD returns PHP 5.6.9 for php -v which suggests that the Environment variables are set correctly.

Yet adding the line
AddHandler application/x-httpd-php .php
LoadModule php5_module "c:/php/php5apache2_4.dll"

returns the error Cannot load c:/php/php5apache2_4.dll into server:

I sense the consensus from this post is that the .dll finds an incompatibility with Apache24.
https://www.apachelounge.com/viewtopic.php?t=5229

So if this php5 module is required, why do I only see versions only up to php 5.4? And how to get past this?
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 507

PostPosted: Mon 19 Dec '16 18:45    Post subject: Reply with quote

Download 5.6 from http://windows.php.net/download/
Back to top
sam452



Joined: 19 Dec 2016
Posts: 5
Location: US, Nashville

PostPosted: Mon 19 Dec '16 21:01    Post subject: Need php5apache2_4.dll for PHP 5.6 Reply with quote

Thank you. The latest version from windows.php.net is running on the server. But there is no php5apache2_4.dll in the download.
Is there no need for that library? If so, why would this new apache24 server not serve up PHP files? What is now needed for Apache24 to run PHP files?
Back to top
admin
Site Admin


Joined: 15 Oct 2005
Posts: 507

PostPosted: Mon 19 Dec '16 21:25    Post subject: Reply with quote

The dll is there. In the thread safe download.
Back to top
sam452



Joined: 19 Dec 2016
Posts: 5
Location: US, Nashville

PostPosted: Wed 21 Dec '16 17:33    Post subject: Reply with quote

Yes, but if was running a basic Apache PHP server I would have thought that non-thread safe would be more appropriate. Regardless, switching to thread-safe PHP 5.6 seemed to work. Thanks for the pointer.
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6105
Location: Germany, Next to Hamburg

PostPosted: Thu 22 Dec '16 22:04    Post subject: Reply with quote

You can run the non thead safe version, but only over mod_fcgid
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1