logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Subversion and mod_svn 1.9.7
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads



View previous topic :: View next topic  
Author Message
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Thu 06 Jul '17 0:09    Post subject: Subversion and mod_svn 1.9.7 Reply with quote

Subversion 1.9.6 has received enough votes to be released:
http://mail-archives.apache.org/mod_mbox/subversion-dev/201707.mbox/browser

I am building mod_svn at the moment. Specs:

Generating for Visual Studio 2015

Could not find installed SWIG
Found apr 1.6.2
Found apr-util 1.6.0
Found apr_memcache 1.6.0
Found expat 2.2.1
Found httpd 2.4.26
Found mod_dav 2.4.26
Found openssl 1.0.2l
Found sasl 2.1.27
Found serf 1.3.9
Found sqlite 3.19.3
Found zlib 1.2.11
swig not found; skipping SWIG file generation...

Edit: see https://www.apachelounge.com/viewtopic.php?p=35685#35685

The modules are in the bin folder.


Last edited by Jan-E on Fri 11 Aug '17 4:03; edited 3 times in total
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Thu 06 Jul '17 11:11    Post subject: Reply with quote

Somebody on the subversion-dev mailing list applied a lot of patches before building on/for Windows 10 with VC14:

http://mail-archives.apache.org/mod_mbox/subversion-dev/201707.mbox/<0f517061-15a5-7d57-5be4-b0cbcf283cb0%40posteo.de>

They might be worth looking into. I did not apply anything more than I had to do for building Apr/Apr-util 1.6.x. See https://www.apachelounge.com/viewtopic.php?t=7657 as well.
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Thu 06 Jul '17 13:48    Post subject: Reply with quote

thx
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Fri 07 Jul '17 3:33    Post subject: Reply with quote

try vc9x86 run error?
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Fri 07 Jul '17 22:39    Post subject: Reply with quote

Please try again. There was a mix-up of x86 and x64 binaries. I compiled the x86 vc9 version again:

https://phpdev.toolsforresearch.com/mod_svn-1.9.6-ap24-x86-vc9.zip

All the tests resulted in the following.

Summary of test results:
2189 tests PASSED
110 tests SKIPPED
38 tests XFAILED (1 WORK-IN-PROGRESS)
SUMMARY: All tests successful.
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 3:33    Post subject: Reply with quote

9:29:43 [934] 错误 The Apache service named reported the following error:
>>> \xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3 .
(2017-07-08 17:29:42)
9:29:43 [933] 错误 The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 454 of D:/qampp/apache/conf/httpd.conf: Syntax error on line 1 of D:/qampp/apache/conf/extra/httpd-svn.conf: Cannot load D:/qampp/svnserver/Subversion/modules/mod_dav_svn.so into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6 .
(2017-07-08 17:29:42)

==============================================
apache 2.4.26 vc9
php 5.2

xp run error
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sat 08 Jul '17 8:51    Post subject: Reply with quote

Did you
LoadModule dav_module modules/mod_dav.so
as well?

Then it works with Apache 2.4.26, VC9, PHP 5.3.29 on my laptop.

Apache/2.4.26 (Win32) SVN/1.9.6 mod_fcgid/2.3.9 OpenSSL/1.0.2l-fips PHP/5.3.29

Loaded Modules: core mod_win32 mpm_winnt http_core mod_so mod_access_compat mod_actions mod_alias mod_allowmethods mod_asis mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dav mod_dav_svn mod_deflate mod_dir mod_env mod_filter mod_headers mod_include mod_isapi mod_log_config mod_mime mod_negotiation mod_proxy mod_proxy_http2 mod_session_crypto mod_setenvif mod_socache_shmcb mod_brotli mod_ssl mod_http2 mod_fcgid mod_php5
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 9:34    Post subject: Reply with quote

not file mod_dav.so

3 file:
mod_authz_svn.so
mod_dav_svn.so
mod_dontdothat.so
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sat 08 Jul '17 10:28    Post subject: Reply with quote

mod_dav.so is part of the standard Apache 2.4.26:
http://www.apachehaus.com/cgi-bin/download.plx#APACHE24VC09
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 11:23    Post subject: Reply with quote

See image: http://203.191.145.182/1.png

im ont fine.
your ses zip.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sat 08 Jul '17 12:21    Post subject: Reply with quote

Why are you highligting mod_s* in the Apachehaus zip? mod_dav.so is upwards, among mod_d*. You should combine that one with the mod_dav_svn.so in my zip.
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 13:06    Post subject: Reply with quote

thx. thx
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 14:45    Post subject: Reply with quote

LoadModule dav_module modules/mod_dav.so
#LoadModule dav_fs_module modules/mod_dav_fs.so
#LoadModule dav_lock_module modules/mod_dav_lock.so

LoadModule dav_svn_module "${SVNPATH}/Subversion/modules/mod_dav_svn.so"
LoadModule authz_svn_module "${SVNPATH}/Subversion/modules/mod_authz_svn.so"

is error. ai
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sat 08 Jul '17 14:45    Post subject: Reply with quote

20:41:26 [935] 错误 The Apache service named reported the following error:
>>> \xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3 .
(2017-07-09 04:41:26)
20:41:26 [934] 错误 The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 454 of D:/qampp/apache/conf/httpd.conf: Syntax error on line 1 of D:/qampp/apache/conf/extra/httpd-svn.conf: Cannot load D:/qampp/svnserver/Subversion/modules/mod_dav_svn.so into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6 .
(2017-07-09 04:41:26)
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sat 08 Jul '17 17:15    Post subject: Reply with quote

Put the modules all in the D:\qampp\apache\modules dir and the svn dll's in D:\qampp\apache\bin
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sun 09 Jul '17 4:55    Post subject: Reply with quote

LoadModule dav_module modules/mod_dav.so
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so

10:50:42 [Apache] Apache 启动成功
10:50:40 [937] 错误 The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 44 of D:/qampp/apache/conf/httpd.conf: Cannot load modules/mod_dav_svn.so into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3 .
(2017-07-09 18:50:39)

mod_dav_svn.so md5:
8E32D395A033CCA313CADA9C8A20855B


I try long.
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sun 09 Jul '17 4:56    Post subject: Reply with quote

Microsoft Windows XP Professional
5.1.2600 Service Pack 3 Build 2600
VC++ Redistributable Package:9.0,
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sun 09 Jul '17 6:15    Post subject: Reply with quote

Here is what I did to check if it really works under Windows XP.

1. I downloaded httpd-2.4.26-x86.zip from http://www.apachehaus.com/cgi-bin/download.plx#APACHE24VC09 and extracted it into D:\Apache24
2. I downloaded https://phpdev.toolsforresearch.com/mod_svn-1.9.6-ap24-x86-vc9.zip and extracted it as well in D:\Apache24, overwriting everything that was already there in D:\Apache24\bin (like the *eay32.dll files).
3. I moved the 3 mod_*.so files from D:\Apache24\bin to D:\Apache24\modules
4. I added this to this end of D:\Apache24\conf\httpd.conf:
Code:
LoadModule dav_module modules/mod_dav.so
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so

5. I started Apache by running D:\Apache24\bin\httpd and got the usual warnings about blocking or unblocking.
6. I checked http://localhost and saw the standard Apachehaus index.html: "That's right! If you are seeing this it means that the web server installed at this site is working properly, but has not yet been configured."

Further details:
Code:
D:\Apache24>bin\httpd -V
Server version: Apache/2.4.26 (Win32)
Server built:   Jun 13 2017 23:32:24
Distributed by: The Apache Haus
Compiled with:  Visual Studio 2008
Server's Module Magic Number: 20120211:68
Server loaded:  APR 1.6.2, APR-UTIL 1.6.0
Compiled using: APR 1.6.2, APR-UTIL 1.6.0
Architecture:   32-bit
Server MPM:     WinNT
  threaded:     yes (fixed thread count)
    forked:     no
Server compiled with....
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses disabled)
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=256
 -D HTTPD_ROOT="/Apache24"
 -D HTTPD_EXEC="/Apache24/bin/httpd.exe"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error.log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

* The Apache Haus
* is not affiliated with, or endorsed by, the Apache Software Foundation.
* Apache HTTP Server, Apache, and the Apache feather logo are trademarks of
* The Apache Software Foundation.


D:\Apache24>bin\httpd -M
Loaded Modules:
 core_module (static)
 win32_module (static)
 mpm_winnt_module (static)
 http_module (static)
 so_module (static)
 actions_module (shared)
 alias_module (shared)
 allowmethods_module (shared)
 asis_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_groupfile_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 cgi_module (shared)
 dir_module (shared)
 env_module (shared)
 include_module (shared)
 info_module (shared)
 isapi_module (shared)
 log_config_module (shared)
 mime_module (shared)
 negotiation_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)
 dav_module (shared)
 dav_svn_module (shared)
 authz_svn_module (shared)

D:\Apache24>ver

Microsoft Windows XP [Version 5.1.2600]

If the same installation on your machine does not work, I really would not know what is going wrong.
Back to top
Jan-E



Joined: 09 Mar 2012
Posts: 780
Location: Amsterdam, NL, EU

PostPosted: Sun 09 Jul '17 6:24    Post subject: Reply with quote

If you still get errors try running 'eventvwr.msc' and look under 'Application' at the details of the error (if the error is logged there).
Back to top
spser



Joined: 29 Aug 2016
Posts: 28

PostPosted: Sun 09 Jul '17 8:23    Post subject: Reply with quote

Thank you very much. I copied DLL into the apache/bin directory, and it started successfully.
But the existing DLL in the original apache/bin directory will be covered. Will it make any difference?
Thanks very much。
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache Building & Member Downloads Goto page 1, 2  Next
Page 1 of 2