logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache 2.4 LogFormat isnt seeing Remote User (%u) properly

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
AMG1978



Joined: 07 Feb 2017
Posts: 7
Location: San Diego, CA

PostPosted: Sat 12 Aug '17 1:19    Post subject: Apache 2.4 LogFormat isnt seeing Remote User (%u) properly Reply with quote

Apache 2.4.25 .26 and .27 tested and confirmed that my LogFormat %u comes in as "-" even when 200 code (good) page loaded. I am using mod_proxy to send the traffic to a backend tomcat server for 1, and Oracle WL proxy module for the other... both have an authenticated user, but my logs in Apache HTTP server won't show it.

I tested a simple .htaccess and .htpasswd and it shows the username properly.

Any clue why this isn't passing back and HTTPD cant log it?
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6225
Location: Germany, Next to Hamburg

PostPosted: Sat 12 Aug '17 14:20    Post subject: Reply with quote

in %u apache will store only a user that was authenticated by itself.

it might work to save the remote user to a local variable and log that.

e.g.

SetEnv REMOTE_USER $REDIRECT_REMOTE_USER

see also https://serverfault.com/questions/180726/remote-user-through-apache-reverse-proxy/231577
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1