logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Loadbalancer issue in 2.4.28 VC11

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
tang_88888



Joined: 10 Jul 2015
Posts: 5

PostPosted: Thu 19 Oct '17 9:50    Post subject: Loadbalancer issue in 2.4.28 VC11 Reply with quote

After updated to Apache httpd 2.4.28 using VC11 Win64, there may be problems with mod_proxy, mod_proxy_ajp, or mod_proxy_balancer.

Previously for two Tomcat servers, I set the "loadfactor" as 50. But after upgraded, the is error:
AH00526: Syntax error on line xxx of C:/Apache/conf/httpd.conf:
BalancerMember LoadFactor must be a number between 1..100

Previous setting:
<Proxy balancer://abcde>
BalancerMember ajp://127.0.0.2:8009/abcde route=A-B loadfactor=50
BalancerMember ajp://127.0.0.3:8009/abcde route=A-B2 loadfactor=50
</Proxy>

In order to startup the Apache server successfully, I need to change the "loadfactor" from 50 to 1. All other numbers is not allowed. Any advise?
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2581
Location: Hilversum, NL, EU

PostPosted: Thu 19 Oct '17 10:26    Post subject: Reply with quote

Looks like a regression with 2.4.28 which is solved in 2.4.29.

Change log 2.4.29:

*) mod_proxy: Fix regression for non decimal loadfactor parameter introduced
in 2.4.28.

Can you test the upcoming 2.4.29 ?

Removed, final available.

Hopefully you can test today, because the voting is lasting an other 1,5 days.


Last edited by Steffen on Mon 23 Oct '17 13:32; edited 1 time in total
Back to top
tang_88888



Joined: 10 Jul 2015
Posts: 5

PostPosted: Thu 19 Oct '17 11:27    Post subject: Reply with quote

Tested 2.4.29 and the issue has been resolved. Thanks!
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1