logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Enable TLSv1.2 with apache 2.2.25 win 32 and openssl 0.9.8y

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
Balaji



Joined: 07 Nov 2017
Posts: 2
Location: Chennai

PostPosted: Wed 08 Nov '17 23:02    Post subject: Enable TLSv1.2 with apache 2.2.25 win 32 and openssl 0.9.8y Reply with quote

We have php application hosted with httpd-2.2.25-win32-x86-openssl-0.9.8y.msi currently configured with TLSv1.0.

I tried to enable with TLSv1.2 with the above apache and openssl version. But it failed with various configuration.

My question is as below please/kindly clarify.
Thanks in Advance.

1.Is to true we cannot enable TLSv1.2 in httpd-2.2.25-win32-x86-openssl-0.9.8y.msi.
2.If we can enable TLSv1.2 with httpd-2.2.25-win32-x86-openssl-0.9.8y.msi, Please share us the advise on the configuration steps to follow on SSL protocol and SSL cipehersuite.

Thanks
Balaji
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Thu 09 Nov '17 1:02    Post subject: Reply with quote

No, OpenSSL 0.9.8 will not speak TLS > 1.0.
Back to top
Balaji



Joined: 07 Nov 2017
Posts: 2
Location: Chennai

PostPosted: Thu 09 Nov '17 1:19    Post subject: Reply with quote

Thanks for your help and time.

Okay, So i am planing to configure with latest version of Apache 2.4.29 Win64 VC15 openssl 1.1.0g which is with the latest openssl version as per the (openssl.org) downloaded from https://www.apachelounge.com/download/.

Is there any way to upgrade openssl only with the same apache version 2.2.25.

Kindly clarify.
Back to top
glsmith
Moderator


Joined: 16 Oct 2007
Posts: 2123
Location: Sun Diego, USA

PostPosted: Thu 09 Nov '17 8:03    Post subject: Reply with quote

Balaji wrote:
Is there any way to upgrade openssl only with the same apache version 2.2.25.


No the APIs do not match on both.

Apache 2.2 & 2.4 have different APIs.
OpenSSL 0.9.8 and 1.1.0 have different APIs so you are out of luck.

The highest OpenSSL version you could upgrade to would be 0.9.8zh, the last release of the 0.9.8 series.

You can also not run a mod_ssl from 2.4.x on 2.2.x nor the other way around.

So you are just going to have to get your hands dirty and upgrade. Note that there are changes to how you configure 2.4, mainly in authorization. So you will need to wrap your head around the authorization part in the 2.4 docs.
http://httpd.apache.org/docs/2.4/howto/auth.html
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1