logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.




HTTP2 broke my directory indexes

 
Post new topic   Reply to topic    Apache Forum Index -> Apache



View previous topic :: View next topic  
Author Message
doonze



Joined: 14 Jan 2018
Posts: 3
Location: Bella Vista

PostPosted: Sun 14 Jan '18 15:11    Post subject: HTTP2 broke my directory indexes Reply with quote

So tonight I got around to enabling HTTP2 across my server. Everything was fine till I went to my pages that serves up indexed folders. They all broke. Here's my setup:

Debian 9.2
Apache 2.4.25

As a test I changed my:

Code:
Protocols h2 http/1.1


to

Code:
Protocols http/1.1


and everything started working again. Here is my current VS that's hosting these indexes but not working:

Code:
<VirtualHost *:443>
    SSLEngine On
    SSLProtocol all -SSLv2 -SSLv3
    SSLCertificateFile /etc/letsencrypt/live/xxxxxx/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/xxxxxxxxxx/privkey.pem
                                                                           

    ServerAdmin sysadmin@xxxxxxx
    ServerName  server.xxxxxxx.xxx
    DocumentRoot /var/www/html/
    Protocols h2 http/1.1
    ServerSignature Off
    LogLevel warn
    ErrorLog /var/log/xxxxxxx
    CustomLog /var/log/xxxxxxxx combined

 
   <Directory /mnt/mybook/media>
        AuthType Basic
        AuthName "Restricted Files"
        AuthUserFile xxxxxxxx.htpasswd
        Require valid-user
        AllowOverride all
        ErrorDocument 401 /errors/index401.html
</Directory>

   Alias "/movies" "/mnt/mybook/media/Movies"
   Alias "/tv" "/mnt/mybook/media/Series"
   Alias "/music" "/mnt/mybook/media/Music"
   Alias "/share" "/mnt/mybook/media/Share"
</VirtualHost> 


I have .htaccess files controlling the indexing headers, options, and details for each directory. The indexes are all those Alias paths there at the bottom.

Chrome tells me "This site canít be reached"

Firefox is a bit more verbos:

Code:
Secure Connection Failed

The connection to home.doonze.net was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.


So, what do you guys think? Google and searches here have giving me nothing. Help!!


Last edited by doonze on Sun 14 Jan '18 23:19; edited 1 time in total
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2662
Location: Hilversum, NL, EU

PostPosted: Sun 14 Jan '18 15:24    Post subject: Reply with quote

Sure you have: LoadModule http2_module modules/mod_http2.so ?

btw.

Since 2.4.25 there are quite some changes with mod_http2, around that time we had 1.8.6 now we have with 2.4.29 version 1.10.12, see https://github.com/icing/mod_h2/releases

Maybe you can upgrade and try again.
Back to top
doonze



Joined: 14 Jan 2018
Posts: 3
Location: Bella Vista

PostPosted: Mon 15 Jan '18 0:03    Post subject: Reply with quote

After considering my options I just turned off H2 for that one VS. It used to be my main VS for my entire site, but all that's left in it anymore is those Indexes.

I really don't want to wander out of LTS on this server. And while I know it will be a long time till Debian upgrades Apache, if this is the only issue I have I'll live with it. I'll report it as a bug to the HTTP2 guys and go from there.

I had been hoping someone else had seen this, and there was some setting or flag I could throw to resolve it. But it seems I'm the only one hitting this issue.

If anyone has any other ideas let me know.
Back to top
nono303



Joined: 20 Dec 2016
Posts: 37
Location: France, Lille

PostPosted: Fri 19 Jan '18 16:30    Post subject: Reply with quote

Hi,

Have you had a look at https://github.com/icing/mod_h2/issues/126 ?
It's look like what you are describing and had been resolve since 1.8.5
Back to top
doonze



Joined: 14 Jan 2018
Posts: 3
Location: Bella Vista

PostPosted: Sat 20 Jan '18 10:19    Post subject: Reply with quote

nono303 wrote:
Hi,

Have you had a look at https://github.com/icing/mod_h2/issues/126 ?
It's look like what you are describing and had been resolve since 1.8.5


I hadn't, but I had been talking to them over there. Turns out I had figured out that was EXACTLY my issue, I just didn't know why. I'm surprised he hadn't jumped on it as my issue right away. Maybe since they've updated and fixed it since then he forgot??

Anyway, just as you linked, my problem was with apache mangling the header when you specified a custom header. I didn't do the research to find out what it was mangling, but the HTML was ok. HTTP2 is much more picky on headers.

I was able to use CSS to achieve what I was using my customer header for, so as far as that went, problem solved.

It seems they have since fixed the problem with HTTP2 and the custom headers, but I'm betting my Debian installation doesn't have the update. I have not been able to figure out what version of HTTP2 I have to verify.

I've since started deploying a php project to replace apache indexing anyway. That way I have more control.

Thanks for the help guys!! Your post would have given me my answer if I hadn't of already figured it out. I just started playing with settings, that's how I discovered where the problem was.

Sorry it took so long to post back up. I've been buried in projects for my website and hadn't reported back.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Apache
Page 1 of 1