logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 


Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.




Issue since replacing/upgrading from php5 to php7

 
Post new topic   Reply to topic    Apache Forum Index -> Other Software



View previous topic :: View next topic  
Author Message
stockton



Joined: 15 Dec 2016
Posts: 3
Location: Midrand, South Africa

PostPosted: Sat 14 Jul '18 10:14    Post subject: Issue since replacing/upgrading from php5 to php7 Reply with quote

Please tell me why mysqli_connect works fine in cli but fails under Apache. I have compared both .ini files and cannot see any difference.
Under Apache I get
Quote:

PHP Fatal error: Call to undefined function mysqli_connect() in /var/www/html/gae3/index.php on line 13, referer: http://stockton.co.za/gae3/

Apache also is telling me:-
Quote:

PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/20131226/mysqli.so' - /usr/lib/php5/20131226/mysqli.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/20131226/mysql.so' - /usr/lib/php5/20131226/mysql.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/20131226/mysqli.so' - /usr/lib/php5/20131226/mysqli.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/20131226/mysql.so' - /usr/lib/php5/20131226/mysql.so: cannot open
shared object file: No such file or directory in Unknown on line 0

Why is it looking for a /usr/lib/php5/20131226/mysqli.so whereas it should be looking at /usr/lib/php/20151012/mysqli.so[
Back to top
James Blond
Moderator


Joined: 19 Jan 2006
Posts: 6391
Location: Germany, Next to Hamburg

PostPosted: Mon 16 Jul '18 15:49    Post subject: Reply with quote

it seems that you have mixed php versions on your installation. 20131226 vs 20151012 shows that. You may uninstall / purge all php from your server and reinstall it.
Back to top


Post new topic   Reply to topic    Apache Forum Index -> Other Software
Page 1 of 1