logo
Apache Lounge
Webmasters

 


About

Forum Index Downloads Search Register Log in  RSS Apache Lounge
 



Keep Server Online

If you find the Apache Lounge, the downloads and overall help useful, please express your satisfaction with a donation.

or

Bitcoin

A donation makes a contribution towards the costs, the time and effort that's going in this site and building.

Thank You! Steffen

Apache Lounge is not sponsored.

Your donations will help to keep this site alive and well, and continuing building binaries.



Apache 2.2 and php 5.1.6 install error + solution

 
Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips



View previous topic :: View next topic  
Author Message
dstrube



Joined: 28 Sep 2006
Posts: 1

PostPosted: Thu 28 Sep '06 22:38    Post subject: Apache 2.2 and php 5.1.6 install error + solution Reply with quote

Problem:
After installing php 5.1.6 and apache 2.2 and following the php documentation on how to configure apache to use php, you get this error when starting the apache service:

Event Type: Error
Event Source: Apache Service
Event ID: 3299
Description:
The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 115 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/php/php5apache2.dll into server: The specified module could not be found.

Solution:
Go here and download php5apache2.dll-php5.1.x.zip.
Follow the instructions in ReadMeFirst.

(I searched for this and only found this site with useful clues, which required me to get a Russian coworker to translate.)
Back to top
halfer



Joined: 31 Jan 2007
Posts: 19

PostPosted: Wed 16 May '07 19:13    Post subject: Reply with quote

Thanks dstrube, very helpful: I've installed this successfully using your assistance. However I noticed that php5apache2.dll-php5.1.x.zip is (at the time of my writing this) no longer available at Apache Lounge. I wonder if the admins of Apache Lounge might consider adding it back in?

I should note that the instructions supplied with this module say that this works with Apache 2.2.0-2.2.3, however I am using it with 2.2.4 and I've not encountered an issue yet. I've not thoroughly tested it admittedly, but generally if it's not going to work, it just wouldn't start at all.
Back to top
Steffen
Moderator


Joined: 15 Oct 2005
Posts: 2580
Location: Hilversum, NL, EU

PostPosted: Wed 16 May '07 19:29    Post subject: Reply with quote

Thanks halfer, I added the download again.


Steffen
Back to top


Post new topic   Reply to topic    Apache Forum Index -> How-to's & Documentation & Tips
Page 1 of 1